MyBB Community Forums
Report & Quoting issue FIXED - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: Report & Quoting issue FIXED (/thread-193019.html)



Report & Quoting issue FIXED - OMGLent - 2016-05-15

Hello, I'm having some problems with my quoting and reporting. I use a custom made theme that has been heavily modified by me. I'm fairly sure that this is a theme issue and was hoping on getting some help on fixing it.




Before I explain further.

Website: https://alliedforums.com


User: Demo
Pass: demo1231

MyBB was only installed about 2 days ago.

-- Mods --
MyBB GoMobile(1.3.2)
PluginLibrary (12) - Doesn't need to be activated
MyAlerts(2.0.2)
Hello World! (2.0) - Always disable
Hello PluginLibrary(hello_pl.php) - Always disabled

Notes: I have already tried disabling all the plugins and the errors persists. 


Errors and how to reporduce --
Clicking "Report" yields no results and spits out -

Uncaught ReferenceError: rootpath is not definedMyBB.popupWindow @ general.js?ver=1804:17Report.reportPost @ report.js?ver=1804:3(anonymous function) @ VM12181:1

Clicking "Quote" yeilds no results and spits out-
Uncaught ReferenceError: cookiePrefix is not definedCookie.get @ general.js?ver=1804:80Thread.multiQuote @ thread.js?ver=1804:8(anonymous function) @ VM12414:1


Changing browsers had no effect.


----- UPDATES (LOOK BELOW DON'T DO THIS ONE) -----

I was able to fix reports by changing the rootpath in general.js to "https://alliedforums.com" or my root domain.

Still looking for a fix to quoting.


----- UPDATE FIXED -----

Go to AdminCP > Home > Template Sets > Your Template Name > Edit Template: headerinclude (located in ungrouped tab)

Add the Following script


<script type="text/javascript">
    var xhr = new XMLHttpRequest(); <-- This one is not necessary. 
    var cookieDomain = "{$mybb->settings['cookiedomain']}";
    var cookiePath = "{$mybb->settings['cookiepath']}";
    var cookiePrefix = "{$mybb->settings['cookieprefix']}";
    var deleteevent_confirm = "{$lang->deleteevent_confirm}";
    var removeattach_confirm = "{$lang->removeattach_confirm}";
    var loading_text = '{$lang->ajax_loading}';
    var saving_changes = '{$lang->saving_changes}';
    var use_xmlhttprequest = "{$mybb->settings['use_xmlhttprequest']}";
    var my_post_key = "{$mybb->post_code}";
    var imagepath = "{$theme['imgdir']}";
</script>

This should fix most of the errors such as my_post_key not defined, quoting, and reporting should be fixed by this because it includes the cookie information.


RE: Report & Quoting issue - .m. - 2016-05-15

please post (or PM me) purchasing proof of the theme (see support eligibility policy)
if you PM me I'd also need a clarification about your forum - is it going to allow warez posting ?


RE: Report & Quoting issue - OMGLent - 2016-05-15

ment for a pm


RE: Report & Quoting issue FIXED - OMGLent - 2016-05-25

Update: Fixed look at bottom of original post for guide.


RE: Report & Quoting issue FIXED - .m. - 2016-05-25

^ somehow I forgot about this topic. Thanks for updating Smile