MyBB Community Forums
[F] Number don't have a comma sign when it's more than a thousand - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Community Archive (https://community.mybb.com/forum-106.html)
+--- Forum: Archived Forums (https://community.mybb.com/forum-143.html)
+---- Forum: Archived Development and Support (https://community.mybb.com/forum-155.html)
+----- Forum: Archived Bug Reports (https://community.mybb.com/forum-74.html)
+------ Forum: MyBB 1.2.7 (https://community.mybb.com/forum-55.html)
+------ Thread: [F] Number don't have a comma sign when it's more than a thousand (/thread-19558.html)



[F] Number don't have a comma sign when it's more than a thousand - chaime - 05-26-2007

Many position in portal page such as Forum Statistics, Online Users and Latest Threads, don't show a comma sign when it's more than a thousand.

How to fix it?
Thank you.


RE: Number don't have a comma sign when it's more than a thousand - LeX- - 05-26-2007

chaime Wrote:Many position in portal page such as Forum Statistics, Online Users and Latest Threads, don't show a comma sign when it's more than a thousand.

How to fix it?
Thank you.

Can you take a look into your General Configuration Settings and see if Thousands Numeric Separator is filled in ?


RE: Number don't have a comma sign when it's more than a thousand - chaime - 05-26-2007

Yes, I already setting it.
It's OK for index page (in stat field - bottom of page) but it not when view in portal page.
This is include this web too.
Look at http://community.mybboard.net/portal.php


RE: Number don't have a comma sign when it's more than a thousand - LeX- - 05-26-2007

chaime Wrote:Yes, I already setting it.
It's OK for index page (in stat field - bottom of page) but it not when view in portal page.
This is include this web too.
Look at http://community.mybboard.net/portal.php

Can't test it, my testforum hasn't got that many posts and stuff =P
But can you try this ::

Open portal.php

Find
	$threadsnum =  $stats['numthreads'];
	$postsnum =  $stats['numposts'];
	$membersnum = $stats['numusers'];

Just don't get why they've put each stat in a variable, they don't get used in the template =/ =P

Change into

	$stats['numthreads'] =  my_number_format($stats['numthreads']);
	$stats['numpost'] =  my_number_format($stats['numposts']);
	$stats['numusers'] =  my_number_format($stats['numusers']);



RE: Number don't have a comma sign when it's more than a thousand - Martin M. - 05-26-2007

Lex- the functions.php file is included in the inc/init.php file so that edit is not needed.


RE: Number don't have a comma sign when it's more than a thousand - LeX- - 05-26-2007

CraKteR Wrote:Lex- the functions.php file is included in the inc/init.php file so that edit is not needed.

ok =P //Removing =P


RE: Number don't have a comma sign when it's more than a thousand - chaime - 05-26-2007

Thank you very much, it's work!


RE: Number don't have a comma sign when it's more than a thousand - Dennis Tsang - 05-27-2007

I think this can be classified as a bug. All numbers should be passed through my_number_format before being outputted.


RE: [F] Number don't have a comma sign when it's more than a thousand - Dennis Tsang - 05-27-2007

This bug has been fixed in the latest code.

Please note the latest code is not live on the site or for download. An update will be released which contains this fix.