MyBB Community Forums
No PHPBB2 merge module - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: Merge System Support (https://community.mybb.com/forum-180.html)
+--- Thread: No PHPBB2 merge module (/thread-195756.html)



No PHPBB2 merge module - Zarkow - 2016-07-17

I searched for modules to convert pbpbb2* to another forum platform and was happy to see that myBB that I run on another site had this.

Now after installing 1.8 it however seems like phpbb2 support is lacking, as I cannot find it in the list using the Merge tool?

How can I rescue my old forum and convert it to myBB?

(* : have to switch from pbpbb2 on a 14 year old forum due to webhost forcing an upgrade to php 7.x from php 5.3)


RE: No PHPBB2 merge module - .m. - 2016-07-17

as you noticed, Merge system for phpbb2 to MyBB 1.8.x is not available

you can locally (eg. XAMPP) upgrade your forum to phpBB3 and then to MyBB 1.8.7


RE: No PHPBB2 merge module - Zarkow - 2016-07-17

Trying to run using PBPBB3 module:


MyBB SQL Error

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1054 - Unknown column 'group_id' in 'where clause'
Query:
SELECT COUNT(*) as count FROM phpbb_users WHERE user_id > 0 AND username != 'Anonymous' AND group_id != 6

Please contact the MyBB Group for technical support.

(2016-07-17, 07:59 AM).m. Wrote: as you noticed, Merge system for phpbb2 to MyBB 1.8.x is not available

you can locally (eg. XAMPP) upgrade your forum to phpBB3 and then to MyBB 1.8.7

I will check it out, but I fear the upgrade to PHPBB3 will fail too if it is strict, as we had several mods.


RE: No PHPBB2 merge module - s3_gunzel - 2016-07-17

(2016-07-17, 08:05 AM)Zarkow Wrote: Trying to run using PBPBB3 module:

phpBB3 was a complete rewrite of their software; thus phpBB2 and phpBB3 have differing MySQL database schemas.


RE: No PHPBB2 merge module - .m. - 2016-07-17

you may have to deactivate (& uninstall) all MODs before upgrading to phpBB 3.1.9