MyBB Community Forums
Smileys not working properly - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: Smileys not working properly (/thread-196001.html)



Smileys not working properly - streettripple - 2016-07-23

Hi, smileys not working properly Eg typing ": )" - without the space, or clicking on the button for a certain smiley means that are put in text but as a blank image.

Not moved them and they are in default smiley folder in images...



thanks a lot


RE: Smileys not working properly - .m. - 2016-07-23

your forum is looking for gif smilie images but MyBB 1.8.x uses png type smilies

you can try running below SQL query to fix it
UPDATE `mybb_smilies` SET  `image`= REPLACE (`image`, '.gif', '.png') WHERE `image` LIKE '%.gif%'; 

see also common sql queries guidance


RE: Smileys not working properly - streettripple - 2016-07-23

(2016-07-23, 12:34 PM).m. Wrote: your forum is looking for gif smilie images but MyBB 1.8.x uses png type smilies

you can try running below SQL query to fix it
UPDATE `mybb_smilies` SET  `image`= REPLACE (`image`, '.gif', '.png') WHERE `image` LIKE '%.gif%'; 

see also common sql queries guidance

So I can either change the file format to gifs.... or run that sql

I went to smilies db and ran that but I get an error saying sql syntax error.....

What now?

So how to fix?


RE: Smileys not working properly - nth - 2016-07-24

And what is the error that you are receiving?


RE: Smileys not working properly - streettripple - 2016-07-24

(2016-07-24, 02:11 PM)nth Wrote: And what is the error that you are receiving?


Error is "

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'UPDATE mybb_smilies SET image= REPLACE (image, '.gif', '.png') WHERE `ima' at line 2

"

- Running the command someone suggested above. 


RE: Smileys not working properly - WallBB - 2016-07-24

Hi,
Can you check if the permission of your images folder is correct ?
Also try to add a gif smiley and see if that is working on your forum.


RE: Smileys not working properly - streettripple - 2016-07-24

EDIT: SOLVED!!!!!!!!!!! -----------
I noticed the actual files were ".gif" - So I changed extension to ".png" and it works...