MyBB Community Forums
PHPBB3 - forums not displayed - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: Merge System Support (https://community.mybb.com/forum-180.html)
+--- Thread: PHPBB3 - forums not displayed (/thread-199789.html)

Pages: 1 2


PHPBB3 - forums not displayed - hjay - 2016-09-03

I seem to have done a successful 'merge' from a phpBB3 installation (was surprised how smooth and easy it was!)....and I can see all my users, they've imported fine.  My admin also tells me that the forums have been imported, albeit that forum 'suggestions' seems imported as a category, while the 'Easter Expedition' is a forum under the 'Imported from PHPBB' category.  

   

The problem is, neither of these forums display in the user view of the board.  The category 'PHPBB Imported' is there, but no forums show under it.  

   

No posts seem to have imported to the admin, either.

Looked like a nice smooth, easy process..... but a bit disappointing!  Sad 

I'm new to MYBB, is there something obvious I'm doing wrong?

thx, hjay


RE: PHPBB3 - forums not displayed - Euan T - 2016-09-03

Hi,

It sounds like it could be the forum cache that needs flushing. It should be flushed by the merge system, but it might have failed to do so.

ACP > Tools & Maintenance > Cache Manager (on the left hand side) > Forums > Rebuild Cache:

[Image: 2wSAzRp.png]

Once that's done, the forums should show up Smile


RE: PHPBB3 - forums not displayed - hjay - 2016-09-03

Hi Euan, thanks for reply.
Just tried that but no joy - then rebuilt all caches, but still nothing.
Also emptied my browser cache, but again no result.

hjay

* I should add that I'm importing a very small phpBB install - only 8 users, 2 forums and 5 posts! It was very early days with phpBB but already it looked way too complex in the admin!


RE: PHPBB3 - forums not displayed - Euan T - 2016-09-03

Interesting. Is this a live board on the internet? If so, could you PM me your URL and details for a temporary admin account? That way I can have a look at the issue for you in couple of minutes.


RE: PHPBB3 - forums not displayed - hjay - 2016-09-03

It's not actually a live board, no - it's on my MAMP localhost. I wanted to see how easy and therefore feasible it would be to change us over to MYBB.


RE: PHPBB3 - forums not displayed - Euan T - 2016-09-03

Ah, that's unfortunate. Can you check the forum permissions for the forum in case they're the problem?


RE: PHPBB3 - forums not displayed - hjay - 2016-09-03

Ah...permissions!

OK, I've delved around in there a bit and made some adjustments! Easter Expedition has now appeared Smile

I guess if I work through all the permissions (still a lot but easier than phpBB!) I might have the full monty!

Thanks for guidance, I'll get back if anything else is unsolvable.

Can't get the 'Suggestions' forum to appear, though....even when given the exact same permissions. ??

If you look at my attachment in my opening post, you'll notice that the position of the Suggestions forum in the list seems to indicate it's a category? Don't know why, but has that got something to do with it not showing?...


RE: PHPBB3 - forums not displayed - Euan T - 2016-09-03

Hi,

The Suggestions forum is still a forum (categories are bold in the list in the ACP), but it's not under a category. If I remember correctly, MyBB requires forums to be inside a category for them to be displayed. You could try moving it to under one of the other categories and see if that makes it show. if so, you'll have to create a category for it Smile


RE: PHPBB3 - forums not displayed - hjay - 2016-09-03

OK, thanks for the tip!


RE: PHPBB3 - forums not displayed - s3_gunzel - 2016-09-05

(2016-09-03, 12:03 PM)Euan T Wrote: If I remember correctly, MyBB requires forums to be inside a category for them to be displayed.

IIRC MyBB will interpose a category for undefined ones. But - that's if I recall correctly...