MyBB Community Forums
[For 1.8] Google SEO 1.8.4 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.8] Google SEO 1.8.4 (/thread-202483.html)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18


RE: Google SEO 1.8.2 - frostschutz - 2018-03-18

(2018-03-18, 02:26 PM)Darkrad Wrote: I have a suspicion Google SEO links break "link searchs" in MyBB.  When I search for a youtube video in my forum I noticed that I can't reach to listed threads and comments, when I tried it in community forums it worked so it's not MyBB related.  Could you check this?

What is "link searchs"? Please be more elaborate / specific ...

Does it work if you go to "Server and Optimization Options" and set "Enable search engine friendly URLs?" to "enabled"?

A proper URL is "url?key=value&key=value", (i.e. ? & & ...)

MyBB does not know how to append URL parameters properly, so with Google SEO, MyBB produces "url&key=value&key=value" (i.e. & & &, ? missing) or "url?key=value?key=value" (i.e. ? ? &, ? duplicated).

It's the reason for this silly rewrite rule:

# Google SEO workaround for search.php highlights:
# Make this rule the first rewrite rule in your .htaccess!
RewriteRule ^([^&]*)&(.*)$ yoursite/$1?$2 [L,QSA,R=301]

And the double ? case is handled by Google SEO Redirect.

Edit: the issue is worse if you use "Lazy Mode" in Google SEO URL settings. That's something I should fix. But it affects only those who actually use that mode...


RE: Google SEO 1.8.2 - sdc100 - 2018-03-20

how do i setup the tag to allow multiple words for the tag?


RE: Google SEO 1.8.2 - Darkrad - 2018-03-21

By link searchs I mean when I search for a link, like when I want to see if that youtube video is shared previously, I search for youtube video link. But I notice with Google SEO plugin it doesn't work basically clicking to search results redirects to main page. This happens only for link searchs.


RE: Google SEO 1.8.2 - RigPa - 2018-04-15

I Have used this plugin for a year and the past month I have had an insane increase in 404 errors. Google search console reports that destination address does not exist and it does not return 404...

Plugin is enabled.

Any ideas?


RE: Google SEO 1.8.2 - Yaba - 2018-05-23

How in the world do you install this?


RE: Google SEO 1.8.2 - Marcelino111 - 2018-06-09

how can i redirect old links in google (which were indexed by previous owner) to the new website. It's something about error 404, i guess. I have anything set on yes in google seo 404, and this line of code in my htaccess.


RE: Google SEO 1.8.2 - karthik5300 - 2018-06-09

Can't install Google SEO on MyBB 1.8.15 as it required PluginLibrary which is not compatible with this version.

anyways how to install it??


RE: Google SEO 1.8.3 - frostschutz - 2018-09-10

Updated to version 1.8.3, hopefully fixing some issues/warnings with PHP 7.2.

Also requires updated version of PluginLibrary.

Please let me know if there are any more problems when running latest PHP. Thank you.


RE: Google SEO 1.8.3 - rfssjz - 2018-09-12

Good plugin, but I need help.

I just found out this morning that all forum, thread, and user URLs take you straight to a 404 page. Up until then, things were fine. I didn't mess with the settings at all.

I also have another MyBB installation on the same server. Funny enough, it's still working just fine.

I've tried applying and reapplying core changes, but nothing seems to do the trick. For the time being, I had to disable URL and redirect settings for this otherwise awesome plugin.


RE: Google SEO 1.8.3 - frostschutz - 2018-09-12

Anything else on that site? For example Wordpress has rewrite rules that can interfere with a forum installed in a subdir. Anyway, hard to tell without knowing more about the site configuration.

Did you uninstall the plugin at any point? To update, you only have to upload the new files, then deactivate/activate not uninstall. Trying to uninstall would also warn you about losing the URL database. Which would be (over time) rebuilt on re-install but not for old redirects, those are lost forever then.

If you uninstalled your best bet would be to restore the google_seo table from a recent backup.