MyBB Community Forums
Missing icon images, see pictures - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Themes (https://community.mybb.com/forum-103.html)
+---- Forum: Theme Support (https://community.mybb.com/forum-10.html)
+---- Thread: Missing icon images, see pictures (/thread-204149.html)

Pages: 1 2 3 4


Missing icon images, see pictures - CyrusG - 2016-10-04

Has performed just like all styles and instructions, but why do you not bring forum images on this theme?

Have tried most of the styles from this member, and everyone gets the same-no image icons.

Other styles, there is no problem with.

https://community.mybb.com/mods.php?action=view&pid=685


RE: Missing icon images, see pictures - User 6029 - 2016-10-04

(2016-10-04, 05:39 PM)CyrusG Wrote: Has performed just like all styles and instructions, but why do you not bring forum images on this theme?

Have tried most of the styles from this member, and everyone gets the same-no image icons.

Other styles, there is no problem with.

https://community.mybb.com/mods.php?action=view&pid=685


I don't clutter the image directory for themes as that has always been a major annoyance in the many years working with mybb..., instead I use a themes directory with theme specific folders like many other bbs have by default. It is an organizational habit I tend to prefer.

Anywhoo.., 
In Upload folder you will find a folder called "themes" place that in your main forum folder. ie: "upload" is equal to main forum directory.

"Upload"/themes/classic

"forum-directory"/themes/classic


RE: Missing icon images, see pictures - CyrusG - 2016-10-05

I have performed just like the other styles that have a directory-upload. And even downloaded XML file and the impoterat theme. But for some reason so do not come with image icons which you can see in the pictures.


RE: Missing icon images, see pictures - Starnova - 2016-10-05

Hi, the images on Devel are not showing on mine the same exact situation as CyrusG.. no images. Sad


RE: Missing icon images, see pictures - User 6029 - 2016-10-06

(2016-10-05, 10:46 PM)Starnova Wrote:  Hi, the images on Devel are not showing on mine the same exact situation as CyrusG.. no images. Sad




I just reinstalled both mentioned themes using the correct directory structure and they both worked fine. Hence if the error cannot be recreated it is clearly a misplacement of the themes folder. As the only other way I could recreate the error was by moving the themes folder to an incorrect location or by turning off images in webdeveloper addon and then I could make an identical screen capture. Turning images back on, bam they are there.

Make sure you place the folders correctly and that your theme image path is also correct in acp.

* do NOT place themes/themename in the images folder

Quote:I don't clutter the image directory for themes as that has always been a major annoyance in the many years working with mybb..., instead I use a themes directory with theme specific folders like many other bbs have by default. It is an organizational habit I tend to prefer. In Upload folder you will find a folder called "themes" place that in your main forum folder.

ie: "upload" is equal to main forum directory.

"Upload"/themes/classic
"forum-directory"/themes/classic

"Upload"/themes/devel
"forum-directory"/themes/devel


Image path for devel:

themes/devel
themes/devel/logo.png

Image path for classic:

themes/classic
themes/classic/logo.png

Here is a tip:

When you download mybb and ectract the zip you get the following main folders:

documentation
upload

When you download any of my themes you get the exact same directory structure with only the extra theme xml in the main directory:

documentation
upload
themename-theme.xml

*in devel there is one additional .txt file that contains info to re-add color options if they didn't import:

Manage Colors:

A list of colors available for this theme. This should be a list of key paired (key=item) colors, for example, blue=Blue. Separate items with a new line.

black=Black
calm=Calm
dawn=Dawn
earth=Earth
flame=Flame
leaf=Leaf
night=Night
sun=Sun
twilight=Twilight
water=Water


RE: Missing icon images, see pictures - CyrusG - 2016-10-06

Now they have followed exactly your description and yet so it does not work. It is a great pity as some temor is good.

Delete all files in the database and added the theme again but may not produce any image icons.


RE: Missing icon images, see pictures - User 6029 - 2016-10-06

(2016-10-06, 04:53 AM)CyrusG Wrote: Now they have followed exactly your description and yet so it does not work. It is a great pity as some temor is good.

Delete all files in the database and added the theme again but may not produce any image icons.

Sounds like perhaps a server side issue? Modifying the database is not relative to the images? Check folder permissions? Sorry you are having trouble. The theme does work, but without looking at your setup. I cannot assertain where your error is. This is the first two complaints and many people use my themes with same directory structure with absolutely no image complaints until now. Usually if I miss adding an image I will add it in the next dev pkg release but eh your problem is not relative to that and still sounds like incorrect folder placement or path settings. Also if you are using webdeveloper addon in your browser make sure you did not accidently disable images and also try clearing browser history.


I am currently on my phone and not by a computer to test further but here is a current screen capture to show that if installed correctly the theme works:
[Image: 25gaw6g.png]

Please note: I have not had a chance to work on this theme further as it has been about six months since I last worked on it. As you can see from when I worked on it here: https://community.mybb.com/thread-185390.html
Perhaps viewing some of that wil give a better understanding of image paths. Also note: I do plan on further improvements and updates if and when my time allows.


RE: Missing icon images, see pictures - CyrusG - 2016-10-06

My Web host has no problem. I tried a different theme that was not from you and it was no problem at all. I have tried the Classic on Firefox, Vivaldi, Chrome, Opera, IE and get the same problem.

All with cleared cookies and cash and with no Add-ons.


RE: Missing icon images, see pictures - User 6029 - 2016-10-06

(2016-10-06, 05:31 AM)CyrusG Wrote: My Web host has no problem. I tried a different theme that was not from you and it was no problem at all. I have tried the Classic on Firefox, Vivaldi, Chrome, Opera, IE and get the same problem.

All with cleared cookies and cash and with no Add-ons.
 
Forum url?   Have you tried right clicking on say where the thead is supposed to be and selecting view image? That should tell you real quick if you placed the the themes directory in the wrong location. Because the logo is not showing that still clues me into it being what I originally stated of being incorrect folder location not incorrect image path setting because if the image path reverted it would still pull a logo from default image folder. Now since that isn't happening that means image paths did not revert so they are still correctly looking for themes/classic folder in your forums main directory which seems  to not be there hence no images thus solidifying my original thought that the folder was not placed correctly. It does not go in images folder period!

Example:

YourSite.whatever/yourforum/themes/classic


YourSite.whatever/yourforum/themes/classic/thead_bg.png


RE: Missing icon images, see pictures - Starnova - 2016-10-06

I too have done that very same thing with the result the same still no images showing. I just do not know why I configured another theme with font awesome and it works.

I have two questions, Is it possible to change or add Font Awesome icons , if so do I need to upload them and how would I configure them?

The other question I have is why are all the forum icons the same except one?  The first forum seems to have a champagne glass.

https://www.ebook-mecca.com

I am not complaining, just curious   Huh