MyBB Community Forums
Is there a way? - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Themes (https://community.mybb.com/forum-103.html)
+---- Forum: Theme Support (https://community.mybb.com/forum-10.html)
+---- Thread: Is there a way? (/thread-205801.html)



Is there a way? - Ghoul - 2016-11-12

I've seen some stuff online about putting portal.php on the root directory and the mybb installation on a subdirectory...but some odd reason...I'm having problems with getting the javascript to work on the Majestic after moving the portal.php to the root and renaming it to index.php for a landing/homepage.

Is there a way of fixing the issue with this?


RE: Is there a way? - WallBB - 2016-11-13

What is the problem you are facing ?


RE: Is there a way? - Corey H - 2016-11-13

What are you trying to do exactly? Migrate the portal to a separate directory or make it the homepage when someone visits your forum?

Let us know.


RE: Is there a way? - Euan T - 2016-11-13

What's your URL? You may need to update some paths in the JavaScript.


RE: Is there a way? - Ghoul - 2016-11-13

The URL is in my signature. But, it's not scrolling the announcement bar or the latest threads, within the theme. This is the theme I have on there.

http://myskins.org/mydownloads.php?action=view_down&did=22

I changed the portal.php to being the landing/homepage off the forum path.

domain/forum is the forum

domain/index.php is the landing/homepage which is still the portal.php


RE: Is there a way? - Euan T - 2016-11-13

Looking at the console, there are several errors:

[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (maj.min.js, line 0)
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (tipsy.js, line 0)
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (classie.js, line 0)
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (tipsy.js, line 0)

Can you paste your headerinclude template please? It looks like it needs updating to use {$mybb->asset_url} as the base path for these resources.


RE: Is there a way? - Ghoul - 2016-11-13

Ended up looking at the coding again in the headerinclude...and fixing the problem with uploading the images of the theme back to the root directory.