MyBB Community Forums
Reply button under each post not working after PHP upgrade to v7.1 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: Reply button under each post not working after PHP upgrade to v7.1 (/thread-206637.html)



Reply button under each post not working after PHP upgrade to v7.1 - tom762 - 2016-12-13

Hi,

as stated in the title, we upgraded the PHP version from 5.6 to 7.1 which resulted in dramatic speed improvement, which is great.

However very soon we found one glitch - "Reply" button under each post stopped working. It should respond with a reply quoting respective post, but it just redirects to a blank page.

One example of this button's link:
http://www.example.com/forum/newreply.php?tid=17745&replyto=130004

Board version is 1.8.8, upgraded from 1.8.7. Otherwise it works great since 1.8.0

I'm attaching a screenshot which shows working and non-working buttons.

Any ideas what could be the problem?

[attachment=38003]


RE: Reply button under each post not working after PHP upgrade to v7.1 - Matt - 2016-12-13

1.8 isn't fully supported on 7.1 yet so we can't guarantee it'll work 100%. The in-progress 1.8.9 release will have 7.1 support.


RE: Reply button under each post not working after PHP upgrade to v7.1 - tom762 - 2016-12-13

(2016-12-13, 10:09 AM)Matt Wrote: 1.8 isn't fully supported on 7.1 yet so we can't guarantee it'll work 100%. The in-progress 1.8.9 release will have 7.1 support.

Ah, ok. Would it be any difference with 7.0 or is it the same story?

Otherwise we'll wait for 1.8.9 and use the Quote workaround by then.


RE: Reply button under each post not working after PHP upgrade to v7.1 - Matt - 2016-12-13

As far as I know, 7.0 should be fine.


RE: Reply button under each post not working after PHP upgrade to v7.1 - tom762 - 2016-12-13

I just checked, and it works fine with 7.0.

Thank you. Wink


RE: Reply button under each post not working after PHP upgrade to v7.1 - johnnyvang - 2016-12-14

On 7.0.13 it also works


RE: Reply button under each post not working after PHP upgrade to v7.1 - gzvirginhair - 2016-12-14

Would it be any difference with 7.0 or is it the same story?


RE: Reply button under each post not working after PHP upgrade to v7.1 - Matt - 2016-12-14

I would assume it is specific to the 7.1 branch and any version of 7.0 is fine.