MyBB Community Forums
Report button doesnt work - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: Report button doesnt work (/thread-206686.html)



Report button doesnt work - slax - 12-15-2016

Im not using myalerts.

This is report.js
var Report = {
	init: function()
	{
		$(document).ready(function(){
		});
	},

	reportPost: function(pid)
	{
		MyBB.popupWindow("/report.php?modal=1&type=post&pid="+pid);
	},
	
	reportUser: function(pid)
	{
		MyBB.popupWindow("/report.php?modal=1&type=profile&pid="+pid);
	},

	reportReputation: function(pid)
	{
		MyBB.popupWindow("/report.php?modal=1&type=reputation&pid="+pid);
	},
	
	submitReport: function(pid)
	{
		// Get form, serialize it and send it
		var datastring = $(".reportData_"+pid).serialize();
		$.ajax({
			type: "POST",
			url: "report.php?modal=1",
			data: datastring,
			dataType: "html",
			success: function(data) {
				// Replace modal HTML
				$('.modal_'+pid).fadeOut('slow', function() {
					$('.modal_'+pid).html(data);
					$('.modal_'+pid).fadeIn('slow');
					$('.modal').fadeIn('slow');
				});
			},
			error: function(){
				  alert(lang.unknown_error);
			}
		});

		return false;
	}
};

Report.init();


Thanks!


RE: Report button doesnt work - Matt - 12-15-2016

Posting your URL, and preferably login details for a test account, would be far more useful than the contents of a javascript file we can already access Smile


RE: Report button doesnt work - Ditger - 12-15-2016

Hey,

just want to know, do you have tried to install myalerts? if this is the case then download the zip again and make sure that every file of myalerts is deleted
if there is still a file then it will crash like u said

but like @matt said before provide a test account for us


RE: Report button doesnt work - slax - 12-15-2016

breakingls.com

id: testing
pw: testing321

(12-15-2016, 10:47 AM)Ditger Wrote: Hey,

just want to know, do you have tried to install myalerts? if this is the case then download the zip again and make sure that every file of myalerts is deleted
if there is still a file then it will crash like u said

but like @matt said before provide a test account for us

Everything deleted