MyBB Community Forums
[solved]1.8.9 doesn't work even after above mods, lot of problems - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: [solved]1.8.9 doesn't work even after above mods, lot of problems (/thread-207134.html)



[solved]1.8.9 doesn't work even after above mods, lot of problems - grad - 2017-01-04

Hi,

I updated today my board to 1.8.9 and discovered also that inline post moderation didn't work. I found the sticky at this forum and applied all the modifications, still no inline post moderation.

I emptied  my browser cache.

Is this solvable or can I go easy back to 1.8.8? I need those post moderation tools.

Thanks.


RE: Inline moderation doesn't work even after above mods - Andre R. - 2017-01-04

Are you sure you have made the changes to the correct theme? I initially made the error of updating a theme that was similarly named but not in use with the required changes


RE: Inline moderation doesn't work even after above mods - grad - 2017-01-04

I only have one theme: Default

   

There is more broken, also Insert picture in post is not working any more.

Remove attachment is now posting and deleting thread is also not working.
It's a real mess.


RE: Inline moderation doesn't work even after above mods - Devilshakerz - 2017-01-04

You can also try Incognito/Private mode to make sure it's not a cache issue. Can you provide your board's URL?


RE: Inline moderation doesn't work even after above mods - grad - 2017-01-04

Can I go back to 1.8.8 is a save manner? 
This 1.8.9 is a big show stopper for me, I have to take the board down now.

Incognito gives the same problems.


RE: 1.8.9 doesn't work even after above mods, lot of problems - Devilshakerz - 2017-01-04

Does your theme rely on JavaScript libraries other than jQuery? It doesn't seem like it at first glance, which would make this line (footer template) unnecessary:
jQuery.noConflict();
and removing it will likely solve the problem.


RE: 1.8.9 doesn't work even after above mods, lot of problems - grad - 2017-01-04

@Devilshakerz , thanks a lot!!!!
Solved!

Can you explain why this is a problem after the update (and why this is a problem in the first place).


RE: [solved]1.8.9 doesn't work even after above mods, lot of problems - Matt - 2017-01-04

I don't think MyBB includes this (as it has no reason to), is it something you had added? It's a problem because jQuery.noConflict() unbinds the $ variable which jQuery usually uses, as $ is also used by other libraries, but as MyBB only uses jQuery, it's unnecessary.


RE: [solved]1.8.9 doesn't work even after above mods, lot of problems - grad - 2017-01-04

Blush Ahhhhh, yes.  I added that "to-top" patch that I found on this forum. 

Sorry.