MyBB Community Forums
[Rejected] Problem with date display in topics - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Development (https://community.mybb.com/forum-161.html)
+--- Forum: MyBB 1.8 Development (https://community.mybb.com/forum-165.html)
+---- Forum: 1.8 Bugs and Issues (https://community.mybb.com/forum-157.html)
+----- Forum: Rejected (https://community.mybb.com/forum-184.html)
+----- Thread: [Rejected] Problem with date display in topics (/thread-215132.html)



Problem with date display in topics - weverson - 2017-12-31

Hello,

Let me explain what happened ...
I tried to change the DATE / TIME display through the configuration in ADMIN, to 24H format changing from "h" to "H", I do not know, but from that point on DATA does not want to appear in the created topics anymore, I returned the settings to the patterns and even so, in my custom theme and also in the pattern.

Look:

Original Theme:
http://prntscr.com/hum9q4

Custom Theme:
http://prntscr.com/hum9fk

Admin Settings:
http://prntscr.com/huma1e

What can be done to re-display, taking into account that this should definitely be a BUG since it does not have the slightest sense it's all original files and Admin configurations.

Thank you in advance for the help I will have.


RE: Problem with date display in topics - labrocca - 2017-12-31

Do you have the language file set for the months?

/inc/languages/[YOURLANG]/global.lang.php

These should be there:

$l['month_1'] = "January";
$l['month_2'] = "February";
$l['month_3'] = "March";
$l['month_4'] = "April";
$l['month_5'] = "May";
$l['month_6'] = "June";
$l['month_7'] = "July";
$l['month_8'] = "August";
$l['month_9'] = "September";
$l['month_10'] = "October";
$l['month_11'] = "November";
$l['month_12'] = "December";

$l['sunday'] = "Sunday";
$l['monday'] = "Monday";
$l['tuesday'] = "Tuesday";
$l['wednesday'] = "Wednesday";
$l['thursday'] = "Thursday";
$l['friday'] = "Friday";
$l['saturday'] = "Saturday";
$l['short_monday'] = "M";
$l['short_tuesday'] = "T";
$l['short_wednesday'] = "W";
$l['short_thursday'] = "T";
$l['short_friday'] = "F";
$l['short_saturday'] = "S";

But of course in the language you've chosen.


RE: Problem with date display in topics - Livewire - 2017-12-31

(2017-12-31, 09:30 PM)labrocca Wrote: Do you have the language file set for the months?

/inc/languages/[YOURLANG]/global.lang.php

These should be there:

$l['month_1'] = "January";
$l['month_2'] = "February";
$l['month_3'] = "March";
$l['month_4'] = "April";
$l['month_5'] = "May";
$l['month_6'] = "June";
$l['month_7'] = "July";
$l['month_8'] = "August";
$l['month_9'] = "September";
$l['month_10'] = "October";
$l['month_11'] = "November";
$l['month_12'] = "December";

$l['sunday'] = "Sunday";
$l['monday'] = "Monday";
$l['tuesday'] = "Tuesday";
$l['wednesday'] = "Wednesday";
$l['thursday'] = "Thursday";
$l['friday'] = "Friday";
$l['saturday'] = "Saturday";
$l['short_monday'] = "M";
$l['short_tuesday'] = "T";
$l['short_wednesday'] = "W";
$l['short_thursday'] = "T";
$l['short_friday'] = "F";
$l['short_saturday'] = "S";

But of course in the language you've chosen.

That's already there, I'm having this same issue. Weird :/


RE: Problem with date display in topics - labrocca - 2017-12-31

And what happens if you change your board to English? This could easily be another MyBB bug.


RE: Problem with date display in topics - Livewire - 2017-12-31

(2017-12-31, 10:56 PM)labrocca Wrote: And what happens if you change your board to English? This could easily be another MyBB bug.

Board is already set to english?
Could be a bug but another forum is on 1.8.14 and doesn't have this problem which is very odd, there's probably a fix but I've searched everywhere can't seem to find any fix to this.

NVM fixed it.. Weverson read this.
https://community.mybb.com/thread-215129-post-1293879.html#pid1293879


RE: Problem with date display in topics - labrocca - 2018-01-01

https://prnt.sc/hum9fk
That's a lot of Spanish for an English default forum.

And glad you fixed it. Likely you edited the default English lang files incorrectly. Suggest you just use Spanish files to avoid corruption defaults.


RE: Problem with date display in topics - Eldenroot - 2018-03-26

So this can be rejected, not a bug