MyBB Community Forums
Updated PHP Version, encountered problem - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: Updated PHP Version, encountered problem (/thread-215430.html)



Updated PHP Version, encountered problem - L Moody - 2018-01-17

Hello.

I updated my PHP version from 5.4 to 7.1 at my server control panel.

Afterward, my forum gave an error message.

So I reverted back to 5.4 and things are working fine.

Is there something I need to do/change within MyBB to make this process go smoothly?


RE: Updated PHP Version, encountered problem - .m. - 2018-01-17

exactly which version of MyBB you are using ? can you post the error message ..

have you checked latest entries of server error log (available at web host panel) .. ?


RE: Updated PHP Version, encountered problem - L Moody - 2018-01-17

From AdminCP:

Current MyBB version: 1.8.14

Current PHP version: 5.4.45 (error began when I updated this to version 7.1)

SQL Engine: MySQL 5.6.36

From cPanel:

Server Error Log is empty (I need to investigate this further)

Here is the exact error message I received from MyBB:

[attachment=39862]


RE: Updated PHP Version, encountered problem - .m. - 2018-01-17

looks like there is some mis-configuration with your php.

check config.php file of MyBB - do you have mysql as the database type ?
if so, changing to mysqli might work. if it doesn't then better to contact your web host.
$config['database']['type'] = 'mysqli';



RE: Updated PHP Version, encountered problem - Matt - 2018-01-17

(Just so you know, this is because the old mysql PHP extension was removed in a newer version of PHP, so it needs to be changed to mysqli as explained above.)


RE: Updated PHP Version, encountered problem - L Moody - 2018-01-17

(2018-01-17, 01:09 PM).m. Wrote: looks like there is some mis-configuration with your php.

check config.php file of MyBB - do you have mysql as the database type ?
if so, changing to mysqli might work. 

$config['database']['type'] = 'mysqli';

Yes, this was precisely the issue.

Once I changed my config.php file from "mysql" to "mysqli", I was able to upgrade my PHP without any further problems. 

Thank you!  Smile