MyBB Community Forums
General Data Protection Regulation (GDPR) - anyone preparing plugins? - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Requests (https://community.mybb.com/forum-65.html)
+---- Thread: General Data Protection Regulation (GDPR) - anyone preparing plugins? (/thread-215816.html)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14


RE: General Data Protection Regulation (GDPR) - anyone preparing plugins? - Eldenroot - 2018-05-25

https://github.com/kawaii/mybb-amnesia


RE: General Data Protection Regulation (GDPR) - anyone preparing plugins? - IntoxNitram - 2018-05-25

(2018-05-25, 03:31 PM)Eldenroot Wrote: https://github.com/kawaii/mybb-amnesia

The amnesia.php file in my plugin area seems to break my plugin page (it turns blank).


RE: General Data Protection Regulation (GDPR) - anyone preparing plugins? - kingcool52 - 2018-05-25

(2018-05-25, 04:16 PM)IntoxNitram Wrote:
(2018-05-25, 03:31 PM)Eldenroot Wrote: https://github.com/kawaii/mybb-amnesia

The amnesia.php file in my plugin area seems to break my plugin page (it turns blank).

Happened to me as well.


RE: General Data Protection Regulation (GDPR) - anyone preparing plugins? - NoRules - 2018-05-25

Same here  Sad

Checking the code... in amnesia.php:
// hooks
\amnesia\addHooksNamespace('amnesia\Hooks');

Is this OK?


RE: General Data Protection Regulation (GDPR) - anyone preparing plugins? - andrewjs18 - 2018-05-25

if the plugin is breaking your plugins page, it's probably because you did not meet the minimum requirements for the plugin to work.

as it says on the github readme:

Dependencies

MyBB >= 1.8.15
https://github.com/frostschutz/MyBB-PluginLibrary
PHP >= 7.1


RE: General Data Protection Regulation (GDPR) - anyone preparing plugins? - NoRules - 2018-05-25

(2018-05-25, 06:37 PM)andrewjs18 Wrote: if the plugin is breaking your plugins page, it's probably because you did not meet the minimum requirements for the plugin to work.

as it says on the github readme:

Dependencies

   MyBB >= 1.8.15
   https://github.com/frostschutz/MyBB-PluginLibrary
   PHP >= 7.1

Hi, I forgot to install MyBB-PluginLibrary as you said, but after install it, same problem happens.

My PHP is  7.0.30 so I'll upgrade it ASAP and I'll report later.

Thank you andrewjs18


RE: General Data Protection Regulation (GDPR) - anyone preparing plugins? - Eldenroot - 2018-05-25

This plugin works fine, you just need php 7.1 at least Smile


RE: General Data Protection Regulation (GDPR) - anyone preparing plugins? - NoRules - 2018-05-25

(2018-05-25, 07:18 PM)Eldenroot Wrote: This plugin works fine, you just need php 7.1 at least Smile

Yeah, with PHP 7.2.5 installed, the plugin page problem disappears.

I keep on testing!  Smile


RE: General Data Protection Regulation (GDPR) - anyone preparing plugins? - IntoxNitram - 2018-05-25

Thought I had it, didn't realise my php version was so out of date (had 5.6)

Where exactly do the members select to make data anonymous?


RE: General Data Protection Regulation (GDPR) - anyone preparing plugins? - andrewjs18 - 2018-05-25

(2018-05-25, 08:43 PM)IntoxNitram Wrote: Thought I had it, didn't realise my php version was so out of date (had 5.6)

Where exactly do the members select to make data anonymous?

this is done on the plugin side of things. check in the plugin settings, it's in there.