MyBB Community Forums
All threads show blank page. (Reinstall everything?) - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: All threads show blank page. (Reinstall everything?) (/thread-216118.html)

Pages: 1 2


All threads show blank page. (Reinstall everything?) - Moseby - 2018-02-28

So I have a forum that I almost just got done with all the plugins and styling, and now I can't show any threads because all that show are blank pages. 

The forum is: https://125.nu/forum

I would like to reset everything so it can work again but I don't wan't to loose any styling or plugins etc. 
Is this possible? Or is there any other way to fix this? 
Thanks a lot


RE: All threads show blank page. (Reinstall everything?) - Ikerepc - 2018-02-28

Well, probably it's happening because of some plugin or style...

You can export theme in ACP -> Templates & Style -> Export theme.
Save it somewhere on your computer or host so you can re-upload it later.
Remember plugins you are using and download them again.

Try uploading one by one. Both theme and plugins to see after each if showthread is working. Maybe some of that can cause showthreads to fail.


RE: All threads show blank page. (Reinstall everything?) - Moseby - 2018-02-28

(2018-02-28, 08:48 AM)Ikerepc Wrote: Well, probably it's happening because of some plugin or style...

You can export theme in ACP -> Templates & Style -> Export theme.
Save it somewhere on your computer or host so you can re-upload it later.
Remember plugins you are using and download them again.

Try  uploading one by one. Both theme and plugins to see after each if showthread is working. Maybe some of that can cause showthreads to fail.
Thanks! 

I have exported the theme, but what now? Do I remove everything and start all over? Or is there a way to just reset everything via the ACP?


RE: All threads show blank page. (Reinstall everything?) - .m. - 2018-02-28

not sure what could be cause of it.

can you check latest entries of server error log to find the cause of blank page
[Server Error 500] the error log should be available at your web host control panel

if admin panel login works fine then you can disable all the plugins temporarily & check if it helps
forum admin panel >> Configuration >> General Configuration >> disable plugins


RE: All threads show blank page. (Reinstall everything?) - Moseby - 2018-02-28

(2018-02-28, 09:25 AM).m. Wrote: not sure what could be cause of it.

can you check latest entries of server error log to find the cause of blank page
[Server Error 500] the error log should be available at your web host control panel

if admin panel login works fine then you can disable all the plugins temporarily & check if it helps
forum admin panel >> Configuration >> General Configuration >> disable plugins

This is the error I get from the page when showing Server error: 
Parse error: syntax error, unexpected '' (T_ENCAPSED_AND_WHITESPACE), expecting identifier (T_STRING) or variable (T_VARIABLE) or number (T_NUM_STRING) in /www/webvol33/8q/g556vztcb8kdm4f/125.nu/public_html/forum/showthread.php(1561) : eval()'d code on line 53
This is what is on line 1561 on Showthread.php: 
eval("\$showthread = \".$templates->get("showthread")."\";");



RE: All threads show blank page. (Reinstall everything?) - .m. - 2018-02-28

^ check showthread template of the theme [active theme you are using]
can you post content from lines 50 - 55


RE: All threads show blank page. (Reinstall everything?) - Moseby - 2018-02-28

(2018-02-28, 10:55 AM).m. Wrote: ^ check showthread template of the theme [active theme you are using]
can you post content from lines 50 - 55

This is the code from 49-56: 

				</div>
				
			</td>
			<?=my_date($mybb->settings['dateformat'], $thread['dateline'])?>
		<?=my_date($mybb->settings['timeformat'], $thread['dateline'])?> 
		</tr>
		
<tr><td id="posts_container">


Thanks again


RE: All threads show blank page. (Reinstall everything?) - .m. - 2018-02-28

do you have PHP in Templates plugin installed & activated ?
which theme actually you are using ?


RE: All threads show blank page. (Reinstall everything?) - Moseby - 2018-02-28

(2018-02-28, 11:33 AM).m. Wrote: do you have PHP in Templates plugin  installed & activated ?
which theme actually you are using ?

No I don't. And currently all plugins are disabled. 
Theme name is sleeq


RE: All threads show blank page. (Reinstall everything?) - .m. - 2018-02-28

either you can remove below two lines OR install & activate above referred plugin
<?=my_date($mybb->settings['dateformat'], $thread['dateline'])?>
        <?=my_date($mybb->settings['timeformat'], $thread['dateline'])?>