MyBB Community Forums
quick edit showed garbled text - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: quick edit showed garbled text (/thread-218560.html)



quick edit showed garbled text - 8guawong - 2018-07-09

1. how to set it so the editor does not use WYSIWYG but default to source editor?
what i tried
- https://community.mybb.com/thread-194944-post-1228431.html#pid1228431 but still uses WYSIWYG
- https://community.mybb.com/thread-218253.html this removes the toolbar completely which is not what i want
- https://community.mybb.com/thread-165583-post-1133544.html#pid1133544 but still uses WYSIWYG

2. quick edit shows garbled text
before hitting quick edit
   

after hitting quick edit
   

Huh Huh Huh

-------------------- edit ---------------------
for issue #1 i did

ALTER TABLE `mybb_users` CHANGE `sourceeditor` `sourceeditor` TINYINT(1) NOT NULL DEFAULT '1'; 
UPDATE `mybb_users` SET `sourceeditor` = '1' WHERE `sourceeditor` = '0'; 

add
"sourceeditor" => $mybb->get_input('sourceeditor', MyBB::INPUT_INT),

to member.php

add
<tr>
<td valign="top" width="1"><input type="checkbox" class="checkbox" name="sourceeditor" id="sourceeditor" value="1" checked/> </td>
<td valign="top"><span class="smalltext"><label for="sourceeditor">{$lang->source_editor}</label></span></td>
</tr>

to member_register template

add
$l['source_editor'] = "Put the editor in source mode by default";

to

member.lang.php

----------------- edit #2 -------------------------

for my 2nd issue i just remove the use of quick edit

solution from https://community.mybb.com/thread-143432.html