MyBB Community Forums
I have enabled HTTPS with cloudflare - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: I have enabled HTTPS with cloudflare (/thread-219013.html)



I have enabled HTTPS with cloudflare - canadacommunity - 2018-07-30

Hi i have enabled SSL Full Path with cloudflare (FREE VERSION), everything seems to work now but images are showing insecure on a few urls.  I have installed  DVZ Secure Content plugin but nothing seems to have changed for a few urls.

Example: if you go here https://canadacommunity.org/Thread-No-Puppy-Mills-Canada-Kijiji-Boycott it gives a notice of images not secure so my question is there any way i can resolve this? 


RE: I have enabled HTTPS with cloudflare - Serpius - 2018-07-30

(2018-07-30, 12:42 AM)canadacommunity Wrote: Hi i have enabled SSL Full Path with cloudflare (FREE VERSION), everything seems to work now but images are showing insecure on a few urls.  I have installed  DVZ Secure Content plugin but nothing seems to have changed for a few urls.

Example: if you go here https://canadacommunity.org/Thread-No-Puppy-Mills-Canada-Kijiji-Boycott it gives a notice of images not secure so my question is there any way i can resolve this? 

If you are able to download the images directly to your website folder, that should solve the 'insecure' issue since the images will be in the secured portion of your website.

You can put the images inside root/images or create a new folder, but make sure the image links are pointing to the new folder.

That's the only other option that I can think of aside from DVZ Secure plugin.


RE: I have enabled HTTPS with cloudflare - canadacommunity - 2018-07-30

(2018-07-30, 01:06 AM)Serpius Wrote:
(2018-07-30, 12:42 AM)canadacommunity Wrote: Hi i have enabled SSL Full Path with cloudflare (FREE VERSION), everything seems to work now but images are showing insecure on a few urls.  I have installed  DVZ Secure Content plugin but nothing seems to have changed for a few urls.

Example: if you go here https://canadacommunity.org/Thread-No-Puppy-Mills-Canada-Kijiji-Boycott it gives a notice of images not secure so my question is there any way i can resolve this? 

If you are able to download the images directly to your website folder, that should solve the 'insecure' issue since the images will be in the secured portion of your website.

You can put the images inside root/images or create a new folder, but make sure the image links are pointing to the new folder.

That's the only other option that I can think of aside from DVZ Secure plugin.

Thanks for trying to help me, is there any other way?


RE: I have enabled HTTPS with cloudflare - andrewjs18 - 2018-07-30

(2018-07-30, 04:01 AM)canadacommunity Wrote:
(2018-07-30, 01:06 AM)Serpius Wrote:
(2018-07-30, 12:42 AM)canadacommunity Wrote: Hi i have enabled SSL Full Path with cloudflare (FREE VERSION), everything seems to work now but images are showing insecure on a few urls.  I have installed  DVZ Secure Content plugin but nothing seems to have changed for a few urls.

Example: if you go here https://canadacommunity.org/Thread-No-Puppy-Mills-Canada-Kijiji-Boycott it gives a notice of images not secure so my question is there any way i can resolve this? 

If you are able to download the images directly to your website folder, that should solve the 'insecure' issue since the images will be in the secured portion of your website.

You can put the images inside root/images or create a new folder, but make sure the image links are pointing to the new folder.

That's the only other option that I can think of aside from DVZ Secure plugin.

Thanks for trying to help me, is there any other way?


you need to tell dvz secure content where to proxy the insecure images through.

use these settings:

[Image: rGlfngU.png]

[Image: exmWTw0.png]


RE: I have enabled HTTPS with cloudflare - canadacommunity - 2018-07-30

(2018-07-30, 06:24 AM)andrewjs18 Wrote:
(2018-07-30, 04:01 AM)canadacommunity Wrote:
(2018-07-30, 01:06 AM)Serpius Wrote:
(2018-07-30, 12:42 AM)canadacommunity Wrote: Hi i have enabled SSL Full Path with cloudflare (FREE VERSION), everything seems to work now but images are showing insecure on a few urls.  I have installed  DVZ Secure Content plugin but nothing seems to have changed for a few urls.

Example: if you go here https://canadacommunity.org/Thread-No-Puppy-Mills-Canada-Kijiji-Boycott it gives a notice of images not secure so my question is there any way i can resolve this? 

If you are able to download the images directly to your website folder, that should solve the 'insecure' issue since the images will be in the secured portion of your website.

You can put the images inside root/images or create a new folder, but make sure the image links are pointing to the new folder.

That's the only other option that I can think of aside from DVZ Secure plugin.

Thanks for trying to help me, is there any other way?


you need to tell dvz secure content where to proxy the insecure images through.  

use these settings:

[Image: rGlfngU.png]

[Image: exmWTw0.png]

Thanks so much.I will try this now.


RE: I have enabled HTTPS with cloudflare - andrewjs18 - 2018-07-30

(2018-07-30, 06:52 PM)canadacommunity Wrote:
(2018-07-30, 06:24 AM)andrewjs18 Wrote:
(2018-07-30, 04:01 AM)canadacommunity Wrote:
(2018-07-30, 01:06 AM)Serpius Wrote:
(2018-07-30, 12:42 AM)canadacommunity Wrote: Hi i have enabled SSL Full Path with cloudflare (FREE VERSION), everything seems to work now but images are showing insecure on a few urls.  I have installed  DVZ Secure Content plugin but nothing seems to have changed for a few urls.

Example: if you go here https://canadacommunity.org/Thread-No-Puppy-Mills-Canada-Kijiji-Boycott it gives a notice of images not secure so my question is there any way i can resolve this? 

If you are able to download the images directly to your website folder, that should solve the 'insecure' issue since the images will be in the secured portion of your website.

You can put the images inside root/images or create a new folder, but make sure the image links are pointing to the new folder.

That's the only other option that I can think of aside from DVZ Secure plugin.

Thanks for trying to help me, is there any other way?


you need to tell dvz secure content where to proxy the insecure images through.  

use these settings:

[Image: rGlfngU.png]

[Image: exmWTw0.png]

Thanks so much.I will try this now.

for some reason your smilie is causing the mixed content warning:

Thread-No-Puppy-Mills-Canada-Kijiji-Boycott:508 Mixed Content: The page at 'https://canadacommunity.org/Thread-No-Puppy-Mills-Canada-Kijiji-Boycott' was loaded over HTTPS, but requested an insecure image 'http://canadacommunity.org/images/smilies/cool.png'. This content should also be served over HTTPS.


RE: I have enabled HTTPS with cloudflare - canadacommunity - 2018-07-30

Andrew thanks alot, i see you mentioned this content should also be served over HTTPS. how do i go about doing this for smiles?

i guess this is the only way, i will have to edit each smile and put for example the full https url to each smile image.


RE: I have enabled HTTPS with cloudflare - andrewjs18 - 2018-08-04

(2018-07-30, 10:08 PM)canadacommunity Wrote: Andrew thanks alot, i see you mentioned this content should also be served over HTTPS. how do i go about doing this for smiles?

i guess this is the only way, i will have to edit each smile and put for example the full https url to each smile image.

I think when you change your board URL from http:// to https://, it should switch the smilie URL over as well. if it's not, perhaps you have some hardcoded paths in the theme you're using.


RE: I have enabled HTTPS with cloudflare - canadacommunity - 2018-08-04

(2018-08-04, 07:40 PM)andrewjs18 Wrote:
(2018-07-30, 10:08 PM)canadacommunity Wrote: Andrew thanks alot,  i see you mentioned this content should also be served over HTTPS. how do i go about doing this for smiles?

i guess this is the only way, i will have to edit each smile and put for example the full https url to each smile image.

I think when you change your board URL from http:// to https://, it should switch the smilie URL over as well.  if it's not, perhaps you have some hardcoded paths in the theme you're using.

Hi Andrewjs18 (thanks for the help)
Yes the first thing i did was change the url from http to https into the admin panel. Actually I dont think I have anything hardcoded in this theme as im currently using the default theme of MyBB. What i did do to put the smilies into https was put the complete url into each smilie path individually. That seemed to fix the problem out in the end.  Undecided


RE: I have enabled HTTPS with cloudflare - meetdilip - 2018-08-05

Are you using Cloudflare for SSL ? I thought their free version SSL throws a certificate warning with Chrome.