MyBB Community Forums
Login logout Cookie problems. Please watch the attached video - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: Login logout Cookie problems. Please watch the attached video (/thread-219044.html)

Pages: 1 2 3 4


Login logout Cookie problems. Please watch the attached video - hwmana - 07-31-2018

Hello People

We are having a weird problem with our site. Please watch the attached youtube video for the exact problem

Forum link is hardwaremana.com/forums



Whenever I login, it shows not logged in but when I click on any link, the site works just as expected. But logging out continues this problem. It is difficult to explain so I please request you guys to watch the attached video

Please help us out here.

Thanks in advance

Bump.
anyone?


RE: Login logout Cookie problems. Please watch the attached video - hwmana - 08-02-2018

bump. Is there no solution?


RE: Login logout Cookie problems. Please watch the attached video - Ashley1 - 08-02-2018

After you login, and press F5, do you still see the login button - or does the site show you as logged in now ?

What version of php is your hosting server running ?

Your theme looks like it was developed on V1.8.14 of MyBB, but what version is your forum on - in the ACP ?

Post your cookie settings here - what do you have for cookie domain, and cookie path - in the ACP -> configuration -> site details?


RE: Login logout Cookie problems. Please watch the attached video - hwmana - 08-03-2018

(08-02-2018, 06:43 PM)Ashley1 Wrote: After you login, and press F5, do you still see the login button - or does the site show you as logged in now ?

What version of php is your hosting server running ?

Your theme looks like it was developed on V1.8.14 of MyBB, but what version is your forum on - in the ACP ?

Post your cookie settings here - what do you have for cookie domain, and cookie path - in the ACP -> configuration -> site details?

Thanks for the replying ashley

Yes, after refreshing the site shows as logged in

php is 5.6.36

my forum is 1.8.17

[Image: sad.png]


RE: Login logout Cookie problems. Please watch the attached video - Serpius - 08-03-2018

(08-03-2018, 06:41 AM)hwmana Wrote:
(08-02-2018, 06:43 PM)Ashley1 Wrote: After you login, and press F5, do you still see the login button - or does the site show you as logged in now ?

What version of php is your hosting server running ?

Your theme looks like it was developed on V1.8.14 of MyBB, but what version is your forum on - in the ACP ?

Post your cookie settings here - what do you have for cookie domain, and cookie path - in the ACP -> configuration -> site details?

Thanks for the replying ashley

Yes, after refreshing the site shows as logged in

php is 5.6.36

my forum is 1.8.17

[Image: sad.png]

Your settings in Site Details is incorrect.

You need to fix the Cookie Path. You only need the '/' (forward slash) in that line.

This is how I have mine setup.

[Image: 30b7ec359833089093d54c8c448bec63.png]


RE: Login logout Cookie problems. Please watch the attached video - Systmyz - 08-03-2018

Actually, the main link of the forums is www.Hardwaremana.com/Forums . Thus according to that, "/Forums/" will be the right choice. Correct me If I am wrong.


RE: Login logout Cookie problems. Please watch the attached video - Serpius - 08-03-2018

(08-03-2018, 08:14 AM)Systmyz Wrote: Actually, the main link of the forums is www.Hardwaremana.com/Forums . Thus according to that, "/Forums/" will be the right choice. Correct me If I am wrong.


/forums/  -- Thank you to @Ashley1 for correcting me on this. 

Should be the correct input for the Cookie Path line.

The Cookie Domain with the '.' (dot) covers all sub-domains including /forums

Try it and see what happens.


RE: Login logout Cookie problems. Please watch the attached video - linguist - 08-03-2018

(07-31-2018, 05:30 PM)hwmana Wrote: Whenever I login, it shows not logged in but when I click on any link, the site works just as expected. But logging out continues this problem. It is difficult to explain so I please request you guys to watch the attached video

Looks and feels like a cache problem to me.


RE: Login logout Cookie problems. Please watch the attached video - Systmyz - 08-03-2018

Actually, the main link of the forums is www.Hardwaremana.com/Forums . Thus according to that, "/Forums/" will be the right choice in cookie path. Correct me If I am wrong.


RE: Login logout Cookie problems. Please watch the attached video - Serpius - 08-03-2018

(08-03-2018, 08:48 AM)linguist Wrote:
(07-31-2018, 05:30 PM)hwmana Wrote: Whenever I login, it shows not logged in but when I click on any link, the site works just as expected. But logging out continues this problem. It is difficult to explain so I please request you guys to watch the attached video

Looks and feels like a cache problem to me.

It could be that, too. I think you were referencing to the browser cache.

But... that gave me an idea about taking care of the website cache, too. As shown in the screenshot below.

[Image: 2ef1560477f1bfc41a9d2085bf3e897d.png]