MyBB Community Forums
[Error Message] Uncaught js errors in console - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: [Error Message] Uncaught js errors in console (/thread-219375.html)



Uncaught js errors in console - tphe1234 - 2018-08-22

Hello MyBB Community,
I'm having a problem with posts quoting on my board.
These are the error i get : 
[Image: image.png]

If you're able to understand what those errors means i'd like to know,
And ofc would love to get a solution.

Thanks in advnaced, Afik.


RE: I cant figure this out - Serpius - 2018-08-22

(2018-08-22, 06:27 PM)tphe1234 Wrote: Hello MyBB Community,
I'm having a problem with posts quoting on my board.
These are the error i get : 
[Image: image.png]

If you're able to understand what those errors means i'd like to know,
And ofc would love to get a solution.

Thanks in advnaced, Afik.


Do you have your AdminCP → Board Settings → Site Details set up like you see in the screenshot below? 

Look at the cookies part. SameSite Cookie Flag and Secure Cookie Flag

[Image: d7018c2041b98e176c94629f8dde547a.png]


RE: I cant figure this out - tphe1234 - 2018-08-22

Hay @Serpius, Thanks for replying.
Cookie settings on my board looks fine,Cant find anything wrong over there.
But yet haven't found any solution for this errors hope to find one soon.


RE: I cant figure this out - WallBB - 2018-08-23

(2018-08-22, 09:55 PM)tphe1234 Wrote: Hay @Serpius, Thanks for replying.
Cookie settings on my board looks fine,Cant find anything wrong over there.
But yet haven't found any solution for this errors hope to find one soon.

I feel the reason is because you don't have the cookieSecureFlag variable in headerinclude, add this code in the headerinclude template
	var cookieSecureFlag = "{$mybb->settings['cookiesecureflag']}";

It should be in this place ->
	var cookieDomain = "{$mybb->settings['cookiedomain']}";
	var cookiePath = "{$mybb->settings['cookiepath']}";
	var cookiePrefix = "{$mybb->settings['cookieprefix']}";
	var cookieSecureFlag = "{$mybb->settings['cookiesecureflag']}";

Regards
WallBB


RE: I cant figure this out - tphe1234 - 2018-08-23

(2018-08-23, 06:40 AM)WallBB Wrote:
(2018-08-22, 09:55 PM)tphe1234 Wrote: Hay @Serpius, Thanks for replying.
Cookie settings on my board looks fine,Cant find anything wrong over there.
But yet haven't found any solution for this errors hope to find one soon.

I feel the reason is because you don't have the cookieSecureFlag variable in headerinclude, add this code in the headerinclude template
	var cookieSecureFlag = "{$mybb->settings['cookiesecureflag']}";

It should be in this place ->
	var cookieDomain = "{$mybb->settings['cookiedomain']}";
	var cookiePath = "{$mybb->settings['cookiepath']}";
	var cookiePrefix = "{$mybb->settings['cookieprefix']}";
	var cookieSecureFlag = "{$mybb->settings['cookiesecureflag']}";

Regards
WallBB

Yes!
It worked wonderly thank you very much @WallBB, Much appreiciated.

All the best, Afik.