MyBB Community Forums
MyBB SQL Error after Thread Views task is run - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: MyBB SQL Error after Thread Views task is run (/thread-219911.html)



MyBB SQL Error after Thread Views task is run - tom762 - 09-24-2018

Few days ago I upgraded from v. 1.18.18 to 1.18.19 and suddenly thread counter stopped working everywhere. New threads just keep showing 0 views.

After manually running the "Thread Views" task, this error shows up:


MyBB SQL Error

MyBB has experienced an internal SQL error and cannot continue.

Please contact the MyBB Group for technical support.


This error is new, but similar issue is there for a long time: when looking at any user's profile, Total Threads always shows 0, even though if you click "Find All Threads" from this user, they display correctly?!

I don't know if this is connected or not, but it's important to our users and we need it to work.

Any idea?


RE: MyBB SQL Error after Thread Views task is run - dragonexpert - 09-24-2018

Does it list an error number or description other than that generic? A forum url would also be helpful to post.


RE: MyBB SQL Error after Thread Views task is run - tom762 - 09-25-2018

Thanks for reply.
No, it doesn't list any error number. I copy/pasted the whole error text.

Here's the url: https://www.strelec.si/forum/


RE: MyBB SQL Error after Thread Views task is run - tom762 - 09-26-2018

Update:

At the same time a problem within Tapatalk app appeared... when trying to read any thread, an error shows up:

"This thread may have already been deleted by the administrator. Open in browser."

Of course threads are just fine and are displayed correctly in the browser. Something must have happened in the database during the last update which messed up thread count or something... :/

Please help. I can give more access if needed.

Solved. It was the table mybb_threadviews that was somehow corrupted and had to be dropped and updated from a backup. It works fine now. Smile