MyBB Community Forums
Having Problems while logging in - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: Having Problems while logging in (/thread-219984.html)



Having Problems while logging in - _ItzAmberStarBoy - 09-29-2018

Whenever I try to log in after changing my theme and template of "Square-Theme" it says this

[b]Forums[/b]
Authorization code mismatch. Are you accessing this function correctly? Please go back and try again.


If you need to go to my website here is the address:

http://dynamicscraft.com


RE: Having Problems while logging in - Ashley1 - 09-29-2018

square theme is not an updated theme. You should search the forum for "Authorization code mismatch" for the fix.


RE: Having Problems while logging in - Michael2014 - 09-29-2018

Great suggestion by Ashley,

let me also add, I signed up on your site and tested an account, I believe the problem is caused because login redirect is not working on your site.
also, I believe Your button class is not in sync with the quick login redirect script

<input class="loginbutton" name="submit" type="submit" value="Login" style="cursor: pointer;">

example:
<script type="text/javascript">
$("#quick_login
$("#quick_login input[name='url']").val($(location).attr('href'));
</script>

<a href="{$mybb->settings['bburl']}/member.php?action=login" onclick="$('#quick_login').modal({ fadeDuration: 250, keepelement: true, zIndex: (typeof modal_zindex !== 'undefined' ? modal_zindex : 9999) }); return false;" class="login">{$lang->welcome_login}</a>

in your welcome guest model login template