MyBB Community Forums
[General] Problem with SSL MYBB - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: [General] Problem with SSL MYBB (/thread-221684.html)



Problem with SSL MYBB - weverson - 2019-01-25

Hi guys how are you?

Well, I have a problem with mybb and if anyone can help me, I'm sure that others, too, have passed or will experience the same problem.

PROBLEM:
- When installing the free Let's Encrypt SSL certificate, I noticed that when accessing my Forum it was partially with its bugged fonts.

Here are some prints:
https://www. = http://prntscr.com/mc5biz
https:// (without www.) = http://prntscr.com/mc5bvt

To run the fonts without the www. on https I had to do the following:
http://prntscr.com/mc5cr4

However, there is no way to make both / all the way work ...

Someone has gone through this, could you help me?

Would the SSL certificate do that? And if you use a PAYMENT certificate, maybe?

Thanks in advance!


RE: Problem with SSL MYBB - Mipher - 2019-01-25

Don't include your domain name when you specify the font to load: since you're including a local font, just specify its relative url images/mbr2/fonts/...
The problem should derives from the fact that most browsers don't allow cross-domain resources (including subdomains), such as fonts, and www it's actually a subdomain, even if it shows the same content. It could also be solved manipulating Access-Control-Allow-Origin header when a font is requested or also forcing the redirect from non-www to www (or viceversa).


RE: Problem with SSL MYBB - weverson - 2019-01-28

@Mipher

Thank you for your response ..

I have edited the urls for:
http://prntscr.com/md3i1p

However, it still only shows without the [www.]
With [www.] You simply do not pull the correct fonts ...

Could it be a problem with https certificate as mentioned in the topic opening?

I'll test later, importing the theme into an environment without .https: //

You have an idea of what it can be so you do not have to force use without [www.] And leaving all functional forms.

Since jah Thank you !!


RE: Problem with SSL MYBB - Mipher - 2019-01-29

Oh, I think it's because of MyBB stylesheet directory. You may try to include it in headerinclude in the same way inside style tags, should work. Or allow your domain to Access-Control-Allow-Origin header adding in the .htaccess (found online):

# ----------------------------------------------------------------------
# Allow loading of external fonts
# ----------------------------------------------------------------------
<FilesMatch "\.(ttf|otf|eot|woff)$">
    <IfModule mod_headers.c>
        SetEnvIf Origin "http(s)?://(www\.)?(mubrgames.com.br)$" AccessControlAllowOrigin=$0
        Header add Access-Control-Allow-Origin %{AccessControlAllowOrigin}e env=AccessControlAllowOrigin
        Header merge Vary Origin
    </IfModule>
</FilesMatch>



RE: Problem with SSL MYBB - Omar G. - 2019-01-29

If it works without www then why not just remove it altogether?