MyBB Community Forums
Image resizer not working in 1.2.9 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Requests (https://community.mybb.com/forum-65.html)
+---- Thread: Image resizer not working in 1.2.9 (/thread-22220.html)

Pages: 1 2


Image resizer not working in 1.2.9 - alifx - 2007-08-19

any body got this working in mybb?

http://mods.mybboard.net/view.php?did=306


regards
Smile


RE: Image resizer not working in 1.2.9 - ancan - 2007-08-22

alifx Wrote:any body got this working in mybb?

http://mods.mybboard.net/view.php?did=306


regards
Smile


Some digging revealed that MyBB now have different classes for attachments and other images in a thread.

To fix it, just open imageresizer.php, and change the row

if (document.images[i].className == "postimage")

to

if (document.images[i].className == "attachment")

/Ancan


RE: Image resizer not working in 1.2.9 - Squiddy - 2007-10-06

I also have problem with the imageresizer plugin after I upgraded to version 1.2.9.

I tested to link to a picture in my sig that's big and it wasn't risized at all. The plugin is activated and the setting (under board setting) for it is ok.
I changed the line in imageresizer.php as described in the last post here, and still it's not working (I did not forget to upload it to the plugin directoryRolleyes).

I really really need this plugin to work as some members fails to adapt there signature pictures to the forum width, and my layout is getting destroyed.

//Thx in advance


RE: Image resizer not working in 1.2.9 - Don_Doh - 2007-10-08

I was also having problems with that pluging..
but I found out that if I made the change Ancan suggest,
AND also "change $replace = '<img class="postimage"$1/>';"
to "change $replace = '<img class="attachment"$1/>';"
(in top of the Php-file).

Then i works for me Smile


RE: Image resizer not working in 1.2.9 - Don_Doh - 2007-10-08

For some reason are there a grey box arround the smilies at my forum when i have tis plugun active [Image: a015.gif]

can someone tell me, if this box can be removed without turning off the plugin?


RE: Image resizer not working in 1.2.9 - Squiddy - 2008-02-05

I know this is pretty late, but heck, better late than never...I just saw the post and the everlasting problem was solved Big Grin

Thanks Don_Doh for the solution you provided. Someone should implement these rewritten codes and provide this script as a 1.2.9-and-later-script on the mod pages.

Cheers Wink


RE: Image resizer not working in 1.2.9 - Squiddy - 2008-02-06

Don_Doh Wrote:For some reason are there a grey box arround the smilies at my forum when i have tis plugun active [Image: a015.gif]

can someone tell me, if this box can be removed without turning off the plugin?

I found a solution of this problem:

go to: admin CP / themes / modify / MyBB Default (Default) / edit
The last section should be "additional CSS", find in the box:

img.attachment {
border: 1px solid #E9E5D7;
padding: 2px;
}


Change: border: 1px solid #E9E5D7;
to: border: 0px solid #E9E5D7;

Don't forget to save...

Solved!


RE: Image resizer not working in 1.2.9 - Hatchet - 2008-07-21

Its working now thanks but is there a way to make it work so that there's a bar that says something like "this image is resized - click here to view it full size". like phpBB or IPB has?


RE: Image resizer not working in 1.2.9 - Don_Doh - 2008-07-22

Squiddy, you are welcome, and thanks for you reply Smile
I will try out your solution, on of the comming days Shy


RE: Image resizer not working in 1.2.9 - Flaw - 2008-07-31

I did this changes and the image resizer still doesn't work for me >.<
I mention that I'm using MyBB 1.2.13 and for some reason, I never got this plugin to work and I've been using MyBB for over an year now...
What can I do? I simply can't get the images from my forum posts or signatures resized.