MyBB Community Forums
"The selected plugin does not exist." - Can't Uninstall - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: "The selected plugin does not exist." - Can't Uninstall (/thread-223172.html)



"The selected plugin does not exist." - Can't Uninstall - unisus - 2019-05-26

Why would this error appear? I created a custom plugin; the plugin installed, and appears correctly in the installed list. I see "Deactivate" & "Uninstall" links. I created uninstall & deactivate functions. Everything about the plugin works fine, except when I try to uninstall it, the error comes: The selected plugin does not exist.

The plugin doesn't uninstall, it remains untouched and when I refresh the page the "Deactivate" and "Uninstall" links remain visible as if nothing changed.


RE: "The selected plugin does not exist." - Can't Uninstall - .m. - 2019-05-27

post your plugin's code (in php / code tags) so that someone can check & provide guidance


RE: "The selected plugin does not exist." - Can't Uninstall - unisus - 2019-05-27

I did some digging and it turns out that my plugin have an underscore in it is cutting off the first half. Is there any reason why plugins shouldn't have underscores?


RE: "The selected plugin does not exist." - Can't Uninstall - .m. - 2019-05-27

plugin's functions use underscore [eg. pluginname_info()]
using underscore in the plugin name can be problematic while executing its functions.

edit:
[MyBB Plugins development - basics]