MyBB Community Forums
Add my code to sceditor - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Support (https://community.mybb.com/forum-72.html)
+---- Thread: Add my code to sceditor (/thread-223244.html)



Add my code to sceditor - kbilly - 06-02-2019

Hello!

I would like to insert a mybb code on sceditor on my forum, using the latest version of myBB.

Was interested to install this plugin but i am getting errors installing it.

The code i would like to add is: [hide][/hide] to the sceditor, may be with some fontawesome icon.

Thanks in advance.

Regards.


RE: Add my code to sceditor - .m. - 06-02-2019

Quote:... but i am getting errors installing it.
list those errors or provide screenshot [crop to clearly show errors] so that someone can help


RE: Add my code to sceditor - kbilly - 06-02-2019

Well,in this thread i was just asking if there is another method to add the code.

The error's screenshot has been added in the plugin's thread, where i asked support and have tried to explain everything.

As soon as i copy the plugin's files to my forum directory, it will show myBB SQL error where normally, you see the inactive plugins.So,i can't install it.

Regards.

[attachment=41817]


RE: Add my code to sceditor - .m. - 06-02-2019

^ open the plugin file and search for rows
replace each occurrence with a different word [eg. myrows]
save the file & try using it

Note: php files should be saved with utf-8 encoding without Byte Order Mark.
in general, we use editor like Notepad++ or file editor at web host panel to edit the files.


RE: Add my code to sceditor - kbilly - 06-02-2019

I would like to thankyou for your help.

Everything works fine.


RE: Add my code to sceditor - kbilly - 06-13-2019

After the update to the latest version of myBB, i am facing a problem with the plugin again.

I would like to mention that i have reverted my "codebuttons" template and have switched back to the default myBB editor because of this problem

So, come the problem with this plugin, with plugin disabled, everything works fine but as soon as i enable the plugin, i am getting a black editor with no buttons.Please check the following screenshots.

[attachment=41861]

[attachment=41863]

[attachment=41862]

I need this plugin to work on my forum, so, any help would be appreciated.

Thankyou.