MyBB Community Forums
[Security] The following warnings occurred: - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: [Security] The following warnings occurred: (/thread-223436.html)



The following warnings occurred: - canadacommunity - 06-14-2019

Warning [2] Invalid argument supplied for foreach() - Line: 4278 - File: \inc\functions.php PHP 7.3.1 (WINNT)
File	Line	Function
\inc\functions.php	4278	errorHandler->error
\inc\plugins\prostats.php	2006	get_unviewable_forums
\inc\plugins\prostats.php	1811	ps_GetUnviewable
\inc\plugins\prostats.php	1150	ps_MakeTable
\inc\class_plugins.php	142	prostats_run_index
\index.php	23	pluginSystem->run_hooks


Please anyone know how to fix this error? im running PHP 7.3.1 and this just happened after upgrading to the newest 1.8.21
Thanks You!


RE: The following warnings occurred: - NoRules - 06-14-2019

Hi,

sorry to ask you, but....

Do you deactivate the plugins before the upgrade?

Try to deactivate the prostats plugin and check if the error it's showing or not.


RE: The following warnings occurred: - canadacommunity - 06-14-2019

(06-14-2019, 04:39 PM)NoRules Wrote: Hi,

sorry to ask you, but....

Do you deactivate the plugins before the upgrade?

Try to deactivate the prostats plugin and check if the error it's showing or not.


Actually i dont deactivate plugins one by one but there is a choice of disabling all plugins so yes i do this before upgrading.
forum admin panel >> configuration (settings) >> General Configuration --> Disable All Plugins

Ok, i fixed the problem thanks everyone!