MyBB Community Forums
SCEditor Issues and Resolutions [1.8.21 upgrade] - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: SCEditor Issues and Resolutions [1.8.21 upgrade] (/thread-223638.html)

Pages: 1 2 3


RE: SCEditor Issues and Resolutions [1.8.21 upgrade] - Taipan - 2019-07-13

Thanks effone, the template appears in blue after I reloaded the files in sceditor I was supposed to and following the other steps in the opening post of this thread, and I am still getting the jumbled unusable 'post a new reply' box, and posts made using Quick Reply still feature formatting. 

I think I need someone to actually look at my board. Is there someone with 'know how' that could do this for me? I'll pay!!


RE: SCEditor Issues and Resolutions [1.8.21 upgrade] - Ronshaan - 2019-08-13

OK for me it fixed the issue on my site,
Thank you so much


RE: SCEditor Issues and Resolutions [1.8.21 upgrade] - sandokhane - 2019-08-24

all Ok with me ... but i can't insert blank lines in editor !!!


RE: SCEditor Issues and Resolutions [1.8.21 upgrade] - ninoPlay12 - 2019-09-07

Quote:Your templates "codebuttons" is still outdated. For example it references the directory editor_themes which has been removed in MyBB 1.8.21. Have you tried reverting the template? auto clicker word unscrambler jumble solver
Thank you much @iAndrew to say that that wasn't exactly obvious would be an understatement. I run a forum, I expect the software (pretty much default) to behave!


RE: SCEditor Issues and Resolutions [1.8.21 upgrade] - toeknee - 2019-12-16

Howdy friends, I recently upgraded from 1.8.5 to 1.8.21 and I think I am experiencing the full SCeditor woes. I have tried all the suggestions in this thread and codebuttons are still broken, so no images, no URLs, no emoticons, etc. I tried to do the upgrade process over but naturally the system recognized the 1.8.21 install, so it wouldn't let me do the upgrade. I'm not super-technical, so I know just enough to get myself into this exact predicament. Here is my codebuttons template. Please be gentle.

<link rel="stylesheet" href="{$mybb->asset_url}/jscripts/sceditor/editor_themes/{$theme['editortheme']}" type="text/css" media="all" />
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/sceditor/jquery.sceditor.bbcode.min.js?ver=1805"></script>
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/bbcodes_sceditor.js?ver=1804"></script>
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/sceditor/editor_plugins/undo.js?ver=1805"></script>
<script type="text/javascript">
var partialmode = {$mybb->settings['partialmode']},
opt_editor = {
	plugins: "bbcode,undo",
	style: "{$mybb->asset_url}/jscripts/sceditor/textarea_styles/jquery.sceditor.{$theme['editortheme']}",
	rtl: {$lang->settings['rtl']},
	locale: "mybblang",
	enablePasteFiltering: true,
	emoticonsEnabled: {$emoticons_enabled},
	emoticons: {
		// Emoticons to be included in the dropdown
		dropdown: {
			{$dropdownsmilies}
		},
		// Emoticons to be included in the more section
		more: {
			{$moresmilies}
		},
		// Emoticons that are not shown in the dropdown but will still be converted. Can be used for things like aliases
		hidden: {
			{$hiddensmilies}
		}
	},
	emoticonsCompat: true,
	toolbar: "{$basic1}{$align}{$font}{$size}{$color}{$removeformat}{$basic2}image,{$email}{$link}|video{$emoticon}|{$list}{$code}quote|maximize,source",
};
{$editor_language}
$(function() {
	$("#{$bind}").sceditor(opt_editor);

	MyBBEditor = $("#{$bind}").sceditor("instance");
	{$sourcemode}
});
</script>



RE: SCEditor Issues and Resolutions [1.8.21 upgrade] - mTurtle_ - 2019-12-16

(2019-12-16, 04:46 PM)toeknee Wrote: Howdy friends, I recently upgraded from 1.8.5 to 1.8.21 and I think I am experiencing the full SCeditor woes. I have tried all the suggestions in this thread and codebuttons are still broken, so no images, no URLs, no emoticons, etc. I tried to do the upgrade process over but naturally the system recognized the 1.8.21 install, so it wouldn't let me do the upgrade. I'm not super-technical, so I know just enough to get myself into this exact predicament. Here is my codebuttons template. Please be gentle.

<link rel="stylesheet" href="{$mybb->asset_url}/jscripts/sceditor/editor_themes/{$theme['editortheme']}" type="text/css" media="all" />
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/sceditor/jquery.sceditor.bbcode.min.js?ver=1805"></script>
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/bbcodes_sceditor.js?ver=1804"></script>
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/sceditor/editor_plugins/undo.js?ver=1805"></script>
<script type="text/javascript">
var partialmode = {$mybb->settings['partialmode']},
opt_editor = {
	plugins: "bbcode,undo",
	style: "{$mybb->asset_url}/jscripts/sceditor/textarea_styles/jquery.sceditor.{$theme['editortheme']}",
	rtl: {$lang->settings['rtl']},
	locale: "mybblang",
	enablePasteFiltering: true,
	emoticonsEnabled: {$emoticons_enabled},
	emoticons: {
		// Emoticons to be included in the dropdown
		dropdown: {
			{$dropdownsmilies}
		},
		// Emoticons to be included in the more section
		more: {
			{$moresmilies}
		},
		// Emoticons that are not shown in the dropdown but will still be converted. Can be used for things like aliases
		hidden: {
			{$hiddensmilies}
		}
	},
	emoticonsCompat: true,
	toolbar: "{$basic1}{$align}{$font}{$size}{$color}{$removeformat}{$basic2}image,{$email}{$link}|video{$emoticon}|{$list}{$code}quote|maximize,source",
};
{$editor_language}
$(function() {
	$("#{$bind}").sceditor(opt_editor);

	MyBBEditor = $("#{$bind}").sceditor("instance");
	{$sourcemode}
});
</script>

Hello,
please try using the following:

<link rel="stylesheet" href="{$mybb->asset_url}/jscripts/sceditor/themes/{$theme['editortheme']}" type="text/css" media="all" />
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/sceditor/jquery.sceditor.bbcode.min.js?ver=1821"></script>
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/bbcodes_sceditor.js?ver=1821"></script>
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/sceditor/plugins/undo.js?ver=1821"></script>
<script type="text/javascript">
var partialmode = {$mybb->settings['partialmode']},
opt_editor = {
    plugins: "undo",
    format: "bbcode",
    bbcodeTrim: true,
    style: "{$mybb->asset_url}/jscripts/sceditor/styles/jquery.sceditor.{$theme['editortheme']}?ver=1821",
    rtl: {$lang->settings['rtl']},
    locale: "mybblang",
    width: "100%",
    enablePasteFiltering: true,
    autoUpdate: true,
    emoticonsEnabled: {$emoticons_enabled},
    emoticons: {
        // Emoticons to be included in the dropdown
        dropdown: {
            {$dropdownsmilies}
        },
        // Emoticons to be included in the more section
        more: {
            {$moresmilies}
        },
        // Emoticons that are not shown in the dropdown but will still be converted. Can be used for things like aliases
        hidden: {
            {$hiddensmilies}
        }
    },
    emoticonsCompat: true,
    toolbar: "{$basic1}{$align}{$font}{$size}{$color}{$removeformat}{$basic2}image,{$email}{$link}|video{$emoticon}|{$list}{$code}quote|maximize,source",
};
{$editor_language}
$(function() {
    $("#{$bind}").sceditor(opt_editor);

    MyBBEditor = $("#{$bind}").sceditor("instance");
    {$sourcemode}
});
</script>

Your forum might be using a custom theme template as the original one, for some reason.


RE: SCEditor Issues and Resolutions [1.8.21 upgrade] - toeknee - 2019-12-16

Thanks, mTurtle. I tried that, and it restored the editor, but codebuttons still don't work. To be clear, the buttons are there, and they insert the appropriate code, AND everything looks fine in preview, but after posting, nothing shows up. Any other ideas on things to try?


RE: SCEditor Issues and Resolutions [1.8.21 upgrade] - DJMOKHTAR - 2020-02-04

hello
I want to start typing automatically from the second line after the quote box.
This gap has been removed after upgrading to the new version and now it's not compatible with my template.
[attachment=42532]