MyBB Community Forums
[Error Message] SSL error - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: [Error Message] SSL error (/thread-224259.html)



SSL error - Rzy - 08-13-2019

Hey, so when i go to my website with the ssl (https), the theme doesnt have any design like it look like without css
Screenshot: http://prntscr.com/os5eli


RE: SSL error - Ashley1 - 08-13-2019

https://mybb.com/support/eligibility-policy/


RE: SSL error - gimbal - 08-13-2019

It means the references to the css files are not loading. Basically you need to follow this document:

https://docs.mybb.com/1.8/administration/security/https/

1. You need to make sure your SSL certificate is working - does your browser show the "lock" icon when visiting your website?

2. Go in to ACP > Configuration > Settings > Site Details >
Board URL > https:// ...
Homepage URL > https:// ...
Secure Cookie Flag > Yes

(that should fix the references to css, but don't stop there)

3. You might need to do the "Protocol Redirection" section of that help document by adding code to the top of the .htaccess file at the root of your forum folder (visible and editable in your cPanel > File Manager) assuming your server uses Apache...

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

4. You also need to follow the instructions to search and replace http:// with https:// in the templates.

I also recently posted this:
https://community.mybb.com/thread-224083.html


RE: SSL error - Rzy - 08-13-2019

(08-13-2019, 03:11 PM)gimbal Wrote: It means the references to the css files are not loading. Basically you need to follow this document:

https://docs.mybb.com/1.8/administration/security/https/

1. You need to make sure your SSL certificate is working - does your browser show the "lock" icon when visiting your website?

2. Go in to ACP > Configuration > Settings > Site Details >
Board URL > https:// ...
Homepage URL > https:// ...
Secure Cookie Flag > Yes

(that should fix the references to css, but don't stop there)

3. You might need to do the "Protocol Redirection" section of that help document by adding code to the top of the .htaccess file at the root of your forum folder (visible and editable in your cPanel > File Manager) assuming your server uses Apache...

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

4. You also need to follow the instructions to search and replace http:// with https:// in the templates.

I also recently posted this:
https://community.mybb.com/thread-224083.html
Thank's but where i can go to ACP > Configuration > Settings > Site Details ?


RE: SSL error - gimbal - 08-13-2019

whatever the address for your forum is, add "/admin/" to the end of the address, and log in as the administrator (which you created when you set up the forum.)

example:
https://yourwebsite.com/admin
or
https://yourwebsite.com/forum/admin