MyBB Community Forums
[How To?] Video links not parsing 1.8.22 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: [How To?] Video links not parsing 1.8.22 (/thread-226058.html)



Video links not parsing 1.8.22 - Seeker-Smith - 2020-01-14

I've got a test site running with MyBB and most everything is working. I was able to merge from VB 4.25 to MyBB 1.8.22 without and big issues but I didn't import attachments.

I've check a few posts with youtube links and they have not parsed and are not even links. I've tested Simple Audito Video Embeder (5.0) and AutoMedia (4.1.1). My understanding MyBB would handle this links without an addon but no luch even with the addons.

I also tried the help here https://community.mybb.com/thread-216380...pid1300198. I've updated the file and no luck.

Any help would be appreciated.

Cheers,
Peter


RE: Video links not parsing 1.8.22 - HLFadmin - 2020-01-15

If the URL is tagged with BBcode like so:
[video=youtube]https://www.youtube.com/watch?v=nrmhAvwBfig[/video]
It will preview and play.

Show an example post, and if possible what the post content was before conversion.
Also, your link to a thread is corrupt and results in a 404 error. I'm sure this one is what you intended.
https://community.mybb.com/thread-216380-post-1300198.html#1300198


RE: Video links not parsing 1.8.22 - Seeker-Smith - 2020-01-15

Hi
Thanks for your response. Yes that link is what I tried.

The BBcode is the same on the test and working sites. The test site is running MyBB and the video code is not even a link. As you can see here https://iwebsl.com/showthread.php?tid=39579


RE: Video links not parsing 1.8.22 - Crazycat - 2020-01-15

[video=youtube;uP0EpePxowo]https://www.youtube.com/watch?v=uP0EpePxowo[/video] 
The ;uP0EpePxowo can't be understood with the original MyCode


RE: Video links not parsing 1.8.22 - Seeker-Smith - 2020-01-15

hmmm I wonder if I can run a sql query to eliminate video=youtube;uP0EpePxowo whats after youtube.

Thanks for your help

Taking that out of the link worked. No I need to see if I can run the edit site wide.


RE: Video links not parsing 1.8.22 - Crazycat - 2020-01-15

If you're using MariaDB, it's possible:
update mybb_posts set message=regexp_replace(message, 'video=youtube;[^\]]+]', 'video=youtube]')


RE: Video links not parsing 1.8.22 - Seeker-Smith - 2020-01-15

Hi. No mysql but I'll need to check it still may be possible.

Thanks for the help.
Cheers,
Peter