MyBB Community Forums
Unable to upgrade to 1.8.X from 1.6.18 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: Installation and Upgrades Support (https://community.mybb.com/forum-182.html)
+--- Thread: Unable to upgrade to 1.8.X from 1.6.18 (/thread-226893.html)



Unable to upgrade to 1.8.X from 1.6.18 - cableboy - 2020-03-16

I'm having problems upgrading from 1.6.18 to 1.8.22 on a forum that has 1.3 million posts. I've been using a test dedicated server with a lot of power.

When I start the upgrade process (after verifying my existing Mybb version), there is a 15-second pause and then a 500 Internal Server Error. My error log is functioning but there is no entry in the log. 

Here are things I've tried:

1. Blanking out the IP addresses as recommended here: https://community.mybb.com/thread-191443-post-1217581.html#pid1217581

UPDATE mybb_posts SET `ipaddress`= ''

2. Optimizing the database before upgrade.

3. Deactivating all plugins.

4. Attempting an incremental upgrade to 1.8.6, the first version available to upgrade from 1.6.18.

5. Editing php.ini file to increase max_execution_time to 999 and max_input_time to 999

In all cases, I get the same result of a 15-second delay followed by an Internal Server Error page.

There is one interesting thing to share. Before the upgrade, I deleted roughly 500,000 posts. When I selected the delete option, the screen hung for a minute before showing me an Internal Server Error page. I thought the deletion failed and went to do something else. Ten minutes later, when I logged into admin, it showed me a message saying the deletion was complete. So it was working successfully in the background even though it showed the error page.

On my last failed attempt to upgrade, after getting the Internal Server Error page, the server experienced high load for the next twenty minutes, suggesting that work was still going on in the background. Then the server load came back to zero. I believe the database was upgraded during that time, but there is no way to resume where I left off. If I go back to /install, the wizard wants me to start from the beginning. If I do so, the same thing happens: a 15-second delay followed by an error screen and then a spike in server load for 20 minutes.

Any idea on how to successfully complete the upgrade?


RE: Unable to upgrade to 1.8.X from 1.6.18 - .m. - 2020-03-17

Quote:incremental upgrade to 1.8.6
that is expected to work fine.

Quote:I deleted roughly 500,000 posts
is it through SQL query ? obviously that is a heavy load for the server !

for Internal Server Errors,
have you checked server error log ? latest entries should have a clue.


RE: Unable to upgrade to 1.8.X from 1.6.18 - cableboy - 2020-03-17

I have an update. The server error was being caused by a mod_security trigger. 

I attempted the upgrade again. The background mysql process appeared to complete but the upgrade page is failing to kick to the next step. It's stuck on this page (screenshot attached).

   


RE: Unable to upgrade to 1.8.X from 1.6.18 - .m. - 2020-03-17

looks like you have a large sized database & upgrading is stopping in between / taking longer time

if the problem still exists, perhaps it would be better to do upgrade on local web server [ex. xampp]