MyBB Community Forums
[Pushed] Attachment code isn't stripped off post previews - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Development (https://community.mybb.com/forum-161.html)
+--- Forum: MyBB 1.8 Development (https://community.mybb.com/forum-165.html)
+---- Forum: 1.8 Bugs and Issues (https://community.mybb.com/forum-157.html)
+----- Forum: Pushed (https://community.mybb.com/forum-183.html)
+----- Thread: [Pushed] Attachment code isn't stripped off post previews (/thread-227271.html)



Attachment code isn't stripped off post previews - Omar G. - 2020-04-12

When searching for posts a small preview of its content is displayed to the user within the search.php file but the [attachment=n] code isn't removed.

I think it should be removed.


RE: Attachment code isn't stripped off post previews - noyle - 2020-04-12

I don't think it matters.


RE: Attachment code isn't stripped off post previews - Ben - 2020-05-29

Any further thoughts here?


RE: Attachment code isn't stripped off post previews - Omar G. - 2020-05-29

I find it inconsistent how we strip it off in posts but not in most areas. Maybe the parser should handle these everywhere?


RE: Attachment code isn't stripped off post previews - Ben - 2020-05-29

(2020-05-29, 08:38 PM)OmarĀ G. Wrote: I find it inconsistent how we strip it off in posts but not in most areas. Maybe the parser should handle these everywhere?

It should definitely happen in all places or not at all, imo.


RE: Attachment code isn't stripped off post previews - Ben - 2020-06-02

Hi,

Thank you for your report. We have pushed this issue to our Github repository for further analysis where you can track our commits and progress with fixing this bug. Discussions regarding this bug may also take place there too.

Follow this link to visit the issue on Github: https://github.com/mybb/mybb/issues/4044

Thanks for contributing to MyBB!

Regards,
The MyBB Group