MyBB Community Forums
[Pushed] Editing help document/section seems doesn't check input - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Development (https://community.mybb.com/forum-161.html)
+--- Forum: MyBB 1.8 Development (https://community.mybb.com/forum-165.html)
+---- Forum: 1.8 Bugs and Issues (https://community.mybb.com/forum-157.html)
+----- Forum: Pushed (https://community.mybb.com/forum-183.html)
+----- Thread: [Pushed] Editing help document/section seems doesn't check input (/thread-227342.html)



Editing help document/section seems doesn't check input - noyle - 2020-04-16

Seems not a big problem though.

When editing a document without a valid hid= input:
/admin/index.php?module=config-help_documents&action=edit&hid=

or editing a section without a valid sid= input:
/admin/index.php?module=config-help_documents&action=edit&sid=

will show an edit screen without error, whilst in other modules there will normally be shown with an error.

Besides, the page header of editing an existing document has the link of "editing document" without its "hid". Some other modules also have this issue, but I forget which they are exactly, will update this post later.


RE: Editing help document/section seems doesn't check input - Ben - 2020-05-29

Hi,

Thank you for your report. We have pushed this issue to our Github repository for further analysis where you can track our commits and progress with fixing this bug. Discussions regarding this bug may also take place there too.

Follow this link to visit the issue on Github: https://github.com/mybb/mybb/issues/4023

Thanks for contributing to MyBB!

Regards,
The MyBB Group