MyBB Community Forums
Plugins not working with my theme? - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Resources (https://community.mybb.com/forum-8.html)
+--- Forum: Tutorials (https://community.mybb.com/forum-38.html)
+--- Thread: Plugins not working with my theme? (/thread-227435.html)



Plugins not working with my theme? - Louay - 2020-04-22

if you searched in google Plugins not working with my theme, then you are in the right place now


Step1:


Simply go to ACP=>Configuration=> plugins

uninstall al your plugins

Step2:

go to ACP => Templates & Style => import your theme

Step3:

back to ACP=>Configuration=> plugins

and re-install your plugins


it should work now.


Note: because plugins add some variables to the theme you need to find those variable and add them to your theme if you imported the theme after installing the plugins or just follow the steps above.


RE: Plugins not working with my theme? - Omar G. - 2020-04-22

I would advice against following this.


RE: Plugins not working with my theme? - Louay - 2020-04-24

(2020-04-22, 10:26 PM)OmarĀ G. Wrote: I would advice against following this.
it worked with me when i had the same problem


RE: Plugins not working with my theme? - Darth Apple - 2020-04-24

Thanks for contributing this! Smile

I will say that it's usually better to deactivate/reactivate instead of completely reinstalling. That's probably what Omar G. is referring to. The normal convention is that template edits go into the activate functionality, and database changes, settings, etc. go into the install/uninstall one. So if you deactivate/reactivate (instead of fully reinstalling), you don't lose the plugin's data, settings, etc.

Otherwise this is pretty much what I do every time and it works! Smile