MyBB Community Forums
My heading picture has gone after update to 1.8.24 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: Installation and Upgrades Support (https://community.mybb.com/forum-182.html)
+--- Thread: My heading picture has gone after update to 1.8.24 (/thread-230942.html)



My heading picture has gone after update to 1.8.24 - JimAttrill - 2021-01-22

My heading picture is still there as forum/images/logo.png but it doesn't show on the forum. 

This happened after update to 1.8.24


RE: My heading picture has gone after update to 1.8.24 - Darth Apple - 2021-01-22

Is anything else different after the update? If there are other problems, the update most likely changed/overwrote your header template. In which case we would need to fix the template (a fairly common problem after updates).

Do you have a link that we can look at?


RE: My heading picture has gone after update to 1.8.24 - JimAttrill - 2021-01-22

I get some sort of default MyBB heading now. All this themes and templates makes my head hurt. I just want something simple for a change not ten million different options!

Maybe I should just ask how to show a heading picture on each page!  There must be an easy way because I have done it before!

And you wonder why I don't like to do updates at all because all sorts of stuff happens.


RE: My heading picture has gone after update to 1.8.24 - Darth Apple - 2021-01-22

It sounds like the update did indeed overwrite the header template. This sort of thing unfortunately happens as a result of the template for the default theme changing. It's a little bit of a pain when it does, but it's worth it to have the security updates that come with new versions.

Try this:

1. Back up your theme first (just in case)
2. Import a new copy of the theme you're using into "TEMP"
3. Go to ACP -> Styles & Templates -> Templates -> TEMP templates -> Header templates, and copy/paste the contents of the header template.
4. Go to your current default theme, and replace the contents with the template you just copied from the previous step.

If the header template is indeed the template that got overwritten, this should fix most of your issues. If not, we would be happy to take a closer look with a screenshot/link. Smile


RE: My heading picture has gone after update to 1.8.24 - JimAttrill - 2021-01-22

1. How do I do this?
2 . Ditto
3. I dont have TEMP templates
4. I don't know how to find the current default

So it's all a bit hopeless isn't it?

If I give you the URL and my id and password could you do this for me? 

I would send that id and password by PM of course Angel


RE: My heading picture has gone after update to 1.8.24 - Darth Apple - 2021-01-22

Send me a message, I'll take a look. I might not be able to get to it until a little later tonight, but I'll see what I can do. Go ahead and export your current theme just so you have a backup beforehand. Smile


RE: My heading picture has gone after update to 1.8.24 - JimAttrill - 2021-01-26

Still no joy. How did I get the header picture to work in the first place? I have forgotten. This MyBB stuff makes rocket science look easy. I have been working as a programmer for 25 years and I can't work this stuff out. It make Micro$oft stuff look easy.


RE: My heading picture has gone after update to 1.8.24 - katos - 2021-02-06

Does anything show in it's place, such as a broken image icon?
Can we get your forum URL so that we can take a look at this one please?