MyBB Community Forums
Mybb CSS breaks on any device besides localhost (WAMP Server) - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: Mybb CSS breaks on any device besides localhost (WAMP Server) (/thread-231463.html)



Mybb CSS breaks on any device besides localhost (WAMP Server) - StormLight - 2021-03-01

I created a wamp server about a week ago, and I set it up with myBB. Everything was working fine, until I tried to access the forum from a different computer. It was just a bunch of text and links, but no CSS appeared. EDIT: I wasn't sure what information to give, so just ask my it and I will add it.


RE: Mybb CSS breaks on any device besides localhost (WAMP Server) - Matt - 2021-03-02

Do you mean you're accessing this over a local network? What IP/hostname did you set it up on?


RE: Mybb CSS breaks on any device besides localhost (WAMP Server) - StormLight - 2021-03-02

(2021-03-02, 12:15 AM)Matt Wrote: Do you mean you're accessing this over a local network? What IP/hostname did you set it up on?
I have attempted to access it locally (using the local ip but on the same network) and trying it on a completely different network. It does the same thing either way. (I set it up and port forwarded so it is accessiblesible either way. It ONLY works on the host machine.

bump. I am honestly just gonna buy XenForo Sad


RE: Mybb CSS breaks on any device besides localhost (WAMP Server) - Matt - 2021-03-02

Are you intending to host a live forum from a local machine? That's not really a good idea. You also haven't answered my question, if you can tell me the actual hostname or URL I might be able to see why it's not working. For example, if you've set the Board URL to be http://localhost, then accessing it from another machine won't work because the CSS URLs will be a localhost address, which won't work from another machine. You'd need to set the Board URL to be the IP of the host machine.

You'll probably have the same issue no matter what software you use, it's nothing to do with the software itself, it'll be because the browser can't load CSS files from the IP address you've set the site up on, that's all. If I'm right in thinking you've set the Board URL as http://localhost, you'd have the same problem with literally any software; MyBB, XenForo, WordPress, everything, because that URL will always loop back to the machine you're on, not where the site is hosted.


RE: Mybb CSS breaks on any device besides localhost (WAMP Server) - Crazycat - 2021-03-02

Short way: use the IP of your hosting computer (like 192.168.0.15) rather than 127.0.0.1 or localhost in your bburl config


RE: Mybb CSS breaks on any device besides localhost (WAMP Server) - StormLight - 2021-03-02

(2021-03-02, 12:03 PM)Crazycat Wrote: Short way: use the IP of your hosting computer (like 192.168.0.15) rather than 127.0.0.1 or localhost in your bburl config
Thanks to you and Matt! It is so nice of everyone to help like this Big Grin

Fixed it ty