MyBB Community Forums
[Error Message] I have a problem that I don’t know how to solve - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: [Error Message] I have a problem that I don’t know how to solve (/thread-232047.html)



I have a problem that I don’t know how to solve - siry - 2021-04-07

Hi there There is a problem on my site when logging in, the user name is set correctly, and the password is wrong. The following message appears
MyBB SQL Error

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
    1054 - Unknown column 'loginlockoutexpiry' in 'field list'
Query:
    SELECT loginattempts, loginlockoutexpiry FROM mybb_users WHERE uid='1'

If you're a visitor of this website, please wait a few minutes and try again.

If you are the site owner, please check the MyBB Documentation for help resolving common issues, or get technical help on the MyBB Community Forums. 
[attachment=43990]


RE: I have a problem that I don’t know how to solve - Matt - 2021-04-07

Have you recently upgraded your forum? It looks like you've not run the upgrade script, as this field was added in 1.8.15.


RE: I have a problem that I don’t know how to solve - siry - 2021-04-07

Yes, I upgraded and I am now on version 1.8.26 and
Hey Matt You are always a beautiful person, so whenever you reply to my posts, I find the solution. I planted the following issue
ALTER TABLE mybb_users ADD loginlockoutexpiry int unsigned NOT NULL default 0;

in the database and the problem was solved successfully. Thank you. Thank you very much.


RE: I have a problem that I don’t know how to solve - [ExiTuS] - 2021-04-07

Well, adding this field to the table will solve thise single issue only.

It seems your previous board version was at most 1.8.14 or earlier!? What version is displayed in Admin-CP actually?
There have been made a bunch of changes to the board system since 1.8.15 - I also guess a couple of other database changes.
So I recommend to go through the upgrade procedure to really be updated in terms of database contents.

[ExiTuS]


RE: I have a problem that I don’t know how to solve - siry - 2021-04-08

(2021-04-07, 10:47 PM)[ExiTuS] Wrote: Well, adding this field to the table will solve thise single issue only.

It seems your previous board version was at most 1.8.14 or earlier!? What version is displayed in Admin-CP actually?
There have been made a bunch of changes to the board system since 1.8.15 - I also guess a couple of other database changes.
So I recommend to go through the upgrade procedure to really be updated in terms of database contents.

[ExiTuS]
Version in Control Panel is 1.8.26 and I upgraded Thank you very much