MyBB Community Forums
nginx 500 Server Error - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: Installation and Upgrades Support (https://community.mybb.com/forum-182.html)
+--- Thread: nginx 500 Server Error (/thread-233771.html)



nginx 500 Server Error - matteodev - 2021-10-04

Hello. I wanted to set up MyBB on my VPS but I ran into a problem, after I setup everything and went to the site, I got an nginx 500 Server error. Can someone help?

OS: Debian 11
PHP: PHP 7.4.21
SQL: Ver 15.1 Distrib 10.5.11-MariaDB
MyBB: 1.8.27

Here is my nginx config:

server {

  listen 4040;
  listen 443 ssl;

  server_name forum.matteodev.xyz;

  root /var/www/mybb;

  location / {
    index index.php;
  }

  # Deny access to internal files.
  location ~ /(inc|uploads/avatars) {
    deny all;
  }

  location ~ \.php$ {
    fastcgi_pass unix:/run/php/php7.3-fpm.sock;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    include fastcgi_params;
  }

}



RE: nginx 500 Server Error - Matt - 2021-10-04

We'd need an error message from the error log, a 500 can mean pretty much anything.


RE: nginx 500 Server Error - Crazycat - 2021-10-04

Check your php-fpm :
Quote:fastcgi_pass unix:/run/php/php7.3-fpm.sock;

You said you are using php 7.4, I think the php7.3-fpm.sock doesn't work anymore, I had this funny trouble when upgrading php 7.3 to 7.4.
And also check all the modules which were enabled in php7.3, some can have be "forget" in upgrade


RE: nginx 500 Server Error - matteodev - 2021-10-05

(2021-10-04, 09:28 PM)Crazycat Wrote: Check your php-fpm :
Quote:fastcgi_pass unix:/run/php/php7.3-fpm.sock;

You said you are using php 7.4, I think the php7.3-fpm.sock doesn't work anymore, I had this funny trouble when upgrading php 7.3 to 7.4.
And also check all the modules which were enabled in php7.3, some can have be "forget" in upgrade

I have the php7.4-fpm.sock file in there