MyBB Community Forums
1827 - cannot attach attachements - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: Installation and Upgrades Support (https://community.mybb.com/forum-182.html)
+--- Thread: 1827 - cannot attach attachements (/thread-233963.html)



1827 - cannot attach attachements - cyberreality - 2021-10-11

hello there,

i tried to update from 1.8.26 to 1.8.27 and now cannot attach any file to the message ... so i reverted back to 26 and started "test" forum for 27 to play with.
i found that this functionality has been reworked ( https://github.com/mybb/mybb/pull/4195 ) and need to change theme. well, the question is what and where? yes i made my own theme from scratch so dunno where make any change in order to have this working ...

my "prod" forum running v26 is here https://liquiddoom.net/forum
and "test" forum running v27 is here https://liquiddoom.net/forum_test

when i run default theme on v27 it works while when my own it does not ... i did "Find Updated Templates" but still the same ...


thanks!


RE: 1827 - cannot attach attachements - noyle - 2021-10-12

Please make sure all templates are up-to-date.

AND then, you may need to manually edit a template called post_attachments_new, replace
<div style="pointer-events: none;"</div>

with
<div style="pointer-events: none;"></div>

Mind that there's a missing >. It's an already reported bug and will be fixed in the next release.


RE: 1827 - cannot attach attachements - cyberreality - 2021-10-13

ok, i've fixed this type and ... it's still the same.

templates should be ok, i did "find updated templates" and got "There are currently no templates which have been updated since you last upgraded."



are there any other templates to be checked manually?



the thing is, it works when using default theme while seeing problems when switched to my own.



btw what this means? https://github.com/mybb/mybb/pull/4195#issuecomment-749746749

i compared default ones to mine and are the same, nothing different.

now this one https://github.com/mybb/mybb/pull/4195#issuecomment-756538911
"If someone choose not to implement upload zone the buttons will appear", well i don't need to have new upload zone, old-fashioned way is ok for me. then the question is where to disable this new feature. now when i refresh "post reply" site i can see "new attachement" option for a moment and then it disappear.


RE: 1827 - cannot attach attachements - cyberreality - 2021-10-21

all fixed now! problem was on my side, i use extras.css and there was "drop" variable which was in collision with drop zone, once renamed to "dropmenu" problem is gone.
now running 1828 without any problem ,thanks