MyBB Community Forums
[General] Problem upgrading from 1.8.29 to 1.8.30 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: [General] Problem upgrading from 1.8.29 to 1.8.30 (/thread-235255.html)



Problem upgrading from 1.8.29 to 1.8.30 - Haydn - 2022-03-21

Attempting my first MyBB upgrade: 1.8.29 to 1.8.30. Uploaded all the files except inc/settings.php (as per instructions). When I go to upgrade.php in my browser, the wizard says the installer is locked. I remove the lock file and try again. This time the wizard says "The upgrade process is not needed for this version." If I try to force the upgrade, it says "Welcome to the upgrade wizard for MyBB 1.8.29" and 1.8.29 is not one of the options (latest is 1.8.27) - I guess this is the version I want to upgrade from. Seems I'm trying to install 1.8.29 on top of 1.8.29. What am I doing wrong?

Any help gratefully received!


RE: Problem upgrading from 1.8.29 to 1.8.30 - Matt - 2022-03-21

https://blog.mybb.com/2022/03/09/mybb-1-8-30-released-security-release/
https://mybb.com/versions/1.8.30/

You don't need to run the upgrade script for the 1.8.29 to 1.8.30, you just need to upload the 2 files from the changed files package here.


RE: Problem upgrading from 1.8.29 to 1.8.30 - Haydn - 2022-03-22

(2022-03-21, 03:36 PM)Matt Wrote: https://blog.mybb.com/2022/03/09/mybb-1-8-30-released-security-release/
https://mybb.com/versions/1.8.30/

You don't need to run the upgrade script for the 1.8.29 to 1.8.30, you just need to upload the 2 files from the changed files package here.

Thanks Matt. I don't know why the upgrade instructions didn't explain this!


RE: Problem upgrading from 1.8.29 to 1.8.30 - Matt - 2022-03-22

It's covered on the upgrade docs on the wiki: https://docs.mybb.com/1.8/install/upgrade/ - I think the page in the Documentation folder in the download is much more basic (to be honest it should probably link to the wiki), I have no idea when the documentation in the download was last updated to be honest!

For each upgrade we have a changed files package that contains the files that are different from the last version (assuming you were already up to date), so in this instance it was 1.8.29 to 1.8.30, and only 2 files changed. The changed files package will contain the /install folder if the upgrade script is required, and won't if it's not, so that's a handy way to tell if it's required to run it. The upgrade notes will also confirm it.

If upgrading more than one version, you could either use the individual changed files packages if it's only a handful of versions, or use the full package - then you'd need to check the release notes for the versions you've missed to see if the upgrade script is required, or just try it and see what it lets you select as the old version. However, as long as you stay up to date with versions, you should be able to use the changed files package every time. Hope that helps for future upgrades!