MyBB Community Forums
[F] plugin compatability - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Community Archive (https://community.mybb.com/forum-106.html)
+--- Forum: Archived Forums (https://community.mybb.com/forum-143.html)
+---- Forum: Archived Development and Support (https://community.mybb.com/forum-155.html)
+----- Forum: Archived Bug Reports (https://community.mybb.com/forum-74.html)
+------ Forum: MyBB 1.4.1 (https://community.mybb.com/forum-93.html)
+------ Thread: [F] plugin compatability (/thread-36471.html)

Pages: 1 2


[F] plugin compatability - nitemare - 2008-08-22

for some reason no matter what i enter for the compatability feild of the info function, mybb stil says its incompatable with 1.4.1

i've tried typing in 1401, * and even removng hte line al together, nothing works

yet if i modify the version number in class_core.php back to 1400, it all suddenly works again

this has happend for both of my plugins, including the ems plugin and another i have yet to release

i hope this makes sence to somebody, it doesn't to me

edit ok, i may have found the issue, the 2 plugins that were showing as incompatble were listed one after the other (see first screen shot), now at this point i was focused on getting EMS workig first, so i didn't bother changing the version code of the ad rotar, so ad rotar was set to be 1400 compatable and ems set to 1401, and yet they both apperd as incompatable, i then simply edited the ad rotar and set it to be 1401 compatable, and both now appered compatable(see screen shot)


RE: plugin compatability - Ryan Gordon - 2008-08-23

Can't reproduce. I've set akismet.php compatibility to 1400 and hello.php compatibility to 1401. They both work fine. I would appreciate it if you attached the code here.


RE: plugin compatability - nitemare - 2008-08-23

(2008-08-23, 06:16 AM)Ryan Gordon Wrote: Can't reproduce. I've set akismet.php compatibility to 1400 and hello.php compatibility to 1401. They both work fine. I would appreciate it if you attached the code here.

sure, here are the 2 plugins i'm dealing with, in this situation, ads.php is set to be 1400 compatable, and ems.php is set to be 1401 compatable

Post-Fix Edit: As this issue has been resolved, i've removed the 2 plugins as they were not completly finished


RE: plugin compatability - Yumi - 2008-08-23

It's a bug, the $compatibility_warning variable in /admin/modules/config/plugins.php is never cleared. You need both plugins to have a _is_installed() function to reproduce this.

To fix, find:
if($plugins->is_compatible($codename) == false)
			{
				$compatibility_warning = "<span style=\"color: red;\">".$lang->sprintf($lang->plugin_incompatible, $mybb->version)."</span>";
			}
Add under:
else
			{
				$compatibility_warning = "";
			}



RE: plugin compatability - nitemare - 2008-08-23

ah, i was thinking something like that myself, i just couldn't find it, thanks for your help


[F] plugin compatability - Ryan Gordon - 2008-08-23

Thank you for your bug report.

This bug has been fixed in our internal code repository. Please note that the problem will not be fixed here until these forums are updated.


RE: [F] plugin compatability - Pow-Mia - 2008-09-13

youre welcome Toungue
and thanks im sure it will be alot better now, hope it works.?
zinga update zahers easy adv banner? pweeeeeze?


RE: [F] plugin compatability - v3rax - 2008-09-18

(2008-09-13, 08:57 AM)Pow-Mia Wrote: youre welcome Toungue
and thanks im sure it will be alot better now, hope it works.?
zinga update zahers easy adv banner? pweeeeeze?

OK, I am totally confused... I am trying to get the Ad rotator mod to work on my forum and I am using 1.4.2

I get the "incompatible" warning message.

is there a way for me to fix this?

Keep in mind I am not a programmer..

Please tell me what file I need to edit and where it is located?

Thanks


RE: [F] plugin compatability - nitemare - 2008-09-18

there is no need to edit anything, ad rotar is not yet compatable with 1.4.2, i didn't know it had come out yet, it will be updated in the next few days


RE: [F] plugin compatability - Ryan Gordon - 2008-09-18

I don't think, there should be any need to update your plugin for a maintenance release like this.