MyBB Community Forums
[F] Merge from smf 1.1.7 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Community Archive (https://community.mybb.com/forum-106.html)
+--- Forum: Archived Forums (https://community.mybb.com/forum-143.html)
+---- Forum: Archived Development and Support (https://community.mybb.com/forum-155.html)
+----- Forum: Archived Bug Reports (https://community.mybb.com/forum-74.html)
+------ Forum: MyBB 1.4.2 (https://community.mybb.com/forum-100.html)
+------ Thread: [F] Merge from smf 1.1.7 (/thread-40702.html)

Pages: 1 2


[F] Merge from smf 1.1.7 - krawutke - 2008-11-19

Hi,

I´ve tested the merge system for mybb1.4 and wanted to merge from a smf 1.1.7 board.
But I not all of my data was merged:
- only a few posts were merged
- no sub categories were merged
- no attachments were merged
- and so on

Is there a way to merge from smf 1.1.7 or is this impossible? Or should I merge from smf 1.1.7 to mybb 1.2 and then merge to mybb 1.4?


Best regards
krawutke


RE: Merge from smf 1.1.7 - Ryan Gordon - 2008-11-19

Link to your old board and new board. Also zip up your convert/logs/ directory and PM me it. Let me know what about is missing.


RE: Merge from smf 1.1.7 - krawutke - 2008-11-19

Hi,
old Board: www.faqboard.info
new Board: www.faqboard.info/MyBB

Ok i see in admin area that the forum titles are missing. If I add all the titles the threads seem to be there.
These are the errors at the moment:
- My attachments are still missing
- Three sub boards were below a wrong parent category


RE: Merge from smf 1.1.7 - catfished - 2008-11-19

(2008-11-19, 07:47 PM)krawutke Wrote: Hi,
old Board: www.faqboard.info
new Board: www.faqboard.info/MyBB

Ok i see in admin area that the forum titles are missing. If I add all the titles the threads seem to be there.
These are the errors at the moment:
- My attachments are still missing
- Three sub boards were below a wrong parent category

I'm having the same sort of problems, I too tried merging an SMF 1.1.7 forum to MyBB 1.4 with the SVN Snapshot merge system.

After two attempts I ended up with this:

Old board: http://norcalcarpclub.com/forum/index.php

New board: http://norcalcarpclub.com/newforum/


RE: Merge from smf 1.1.7 - krawutke - 2008-11-19

You have to edit all the forum titles. Then all of the post are back.


RE: Merge from smf 1.1.7 - catfished - 2008-11-19

(2008-11-19, 08:07 PM)krawutke Wrote: You have to edit all the forum titles. Then all of the post are back.

I can't even get to most threads, basically the merge was a disaster. Fortunately, I just tried it as an experiment, obviously it's not ready to go to a stable release. Everything "appeared" to go smoothly during the convert process on the second try with no errors except for lots of "attachment not found" errors while merging attachments but obviously it did not merge correctly.

I am not complaining about this as I realize it's only a test system at this point, just letting folks know that it's not working with SMF 1.1.7 so far, at least not for me or krawutke.


RE: Merge from smf 1.1.7 - Ryan Gordon - 2008-11-19

(2008-11-19, 08:17 PM)catfished Wrote:
(2008-11-19, 08:07 PM)krawutke Wrote: You have to edit all the forum titles. Then all of the post are back.

I can't even get to most threads, basically the merge was a disaster. Fortunately, I just tried it as an experiment, obviously it's not ready to go to a stable release. Everything "appeared" to go smoothly during the convert process on the second try with no errors except for lots of "attachment not found" errors while merging attachments but obviously it did not merge correctly.

I am not complaining about this as I realize it's only a test system at this point, just letting folks know that it's not working with SMF 1.1.7 so far, at least not for me or krawutke.

Send me a ZIP of your /convert/logs/ directory in a PM as well.


Merge from smf 1.1.7 - Ryan Gordon - 2008-11-19

This issue has been updated to confirmed bug report in the MyBB Merge System.

It has been moved to the "Bug Reports" forum.


[F] Merge from smf 1.1.7 - Ryan Gordon - 2008-11-19

This bug has been fixed in the latest version of the MyBB Merge System.

Please note the latest code is not live on the site or for download. An update for the MyBB Merge System will be released which contains this fix.

With regards,
The MyBB Group


RE: [F] Merge from smf 1.1.7 - Ryan Gordon - 2008-11-19

The download package was updated with the fix. It was a simple fix just a misspelling on 2 variables. You can try your conversions now and they should work