MyBB Community Forums
Where Clause Error HELP! - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Community Archive (https://community.mybb.com/forum-106.html)
+--- Forum: Archived Forums (https://community.mybb.com/forum-143.html)
+---- Forum: Archived Development and Support (https://community.mybb.com/forum-155.html)
+----- Forum: MyBB 1.4 (https://community.mybb.com/forum-80.html)
+------ Forum: MyBB Merge System for 1.4 (B4) (https://community.mybb.com/forum-111.html)
+------- Forum: General Support (https://community.mybb.com/forum-112.html)
+------- Thread: Where Clause Error HELP! (/thread-44797.html)



Where Clause Error HELP! - needhelpnow - 2009-02-07

Okay, so I'm converting phpbb3 to mybb 1.2, and I get this error:

MySQL error: 1054
Unknown column 'user_id' in 'where clause'
Query: SELECT COUNT(*) as count FROM mybb_users WHERE user_id > 0 AND username != 'Anonymous' AND group_id != 6

I'm having problems every step of the way, but this one confuses me on a level I didn't know you could be confused. Please help!
Please somebody help!


RE: Where Clause Error HELP! - Ryan Gordon - 2009-02-07

Please remove any modifications you have on your phpBB 3 forum.


RE: Where Clause Error HELP! - needhelpnow - 2009-02-09

(2009-02-07, 07:30 AM)Ryan Gordon Wrote: Please remove any modifications you have on your phpBB 3 forum.

Okay, I just did that. Now I'm getting this error:


Warning: require_once(/home2/thegami4/public_html/prizerebelforum2/forum/inc/db_.php) [function.require-once]: failed to open stream: No such file or directory in /home2/thegami4/public_html/prizerebelforum2/forum/convert/boards/phpbb3.php on line 75

Fatal error: require_once() [function.require]: Failed opening required '/home2/thegami4/public_html/prizerebelforum2/forum/inc/db_.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home2/thegami4/public_html/prizerebelforum2/forum/convert/boards/phpbb3.php on line 75

I have no idea what's wrong
Never mind, I have to start all over. The phpBB software started self destructing and deleting itself. I'm NEVER using phpBB EVER again.