MyBB Community Forums
[1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) (/thread-59652.html)



RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - SkyLineRxx - 2009-11-28

How do I fix this?

[Image: 4vqped.jpg]


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - - G33K - - 2009-11-28

(2009-11-26, 08:38 AM)srch07 Wrote: Thanks for the reply " - G33K - "
Actually, when installing plugin, my member.php wasn't modified by the plugin automatically, so i manually inserted the code found from its plugin file for member.php

I'll try the suggestions you made.. than reply back asap.

NO php files are modified by this plugin, only the templates in the database are modified. Please make sure you know what you're doing and I hope you didn't actually go modifying your member.php file. Read the Installing instructions and follow them properly.
If you want to know more about the template edits, read the following post:
http://community.mybboard.net/thread-59652-post-426555.html#pid426555

(2009-11-27, 07:31 AM)iPod15 Wrote: There is a problem with all of the plugins (because of my theme,) they don't show up because of the template, so I have to add it manually. What do I add for the thanks button and thanked, to show up on profile and posts?

Read this post for the template edits:
http://community.mybboard.net/thread-59652-post-426555.html#pid426555

(2009-11-27, 03:01 PM)Goggalor Wrote:
(2009-11-25, 09:41 PM)- G33K - Wrote:
(2009-11-25, 05:04 PM)Goggalor Wrote: OK I just upgraded to v 1.1 and still have the constant page load issue in IE based browsers.

All other browsers work fine.
All templates are exactly how they should be.

This was tested on a clean install on a test board.

Could this just be a permanent issue with IE? I have a lot of members who still use IE and are not willing to use a new browser. If you think this is going to be a permanent issue, I need to know so I can make a "note" for them to just thank/like and hit refresh and not worry about it.

I will repeat what I have said again, URL, test account, beyond that I can't help you as it works fine for me in IE (IE8 by the way). Have you checked if this is happening on a different system or yours only? What version of IE?

I'm using IE7. IE8 is a nightmare on my computer. Could this be the issue?

It's working perfectly on all other browsers but IE7 for me. Again, I never tested IE8 due to it being a nightmare of slowness adn errors on my computer.

Sending a pm to you now for test acct info.

I checked the test board you sent in PM and it works perfectly as it should in IE8.
I did not test it in IE7 as I don't have access to IE7 right now, once I test it on IE7 I'll update here.

(2009-11-28, 06:52 AM)SkyLineRxx Wrote: How do I fix this?

<snip>

I checked my code and indeed there is an error which is why you got that error. Whats baffling me even more is how this has worked without throwing any error till now! I have used this same code on some of my other plugins too and it has just worked when in actuality it shouldn't have.
For my own curiosity and learning process I would like to investigate this further, so if you don't mind could I know what php and mysql version you're running??

As for the fix to the error, I'm attaching a thankyoulike.php file to this post, download it and put it in inc/plugins overwriting the existing thankyoulike.php file already there. Deactivate and reactivate the plugin and we should be good to go.

I'll also be releasing a bug fix version with this problem fixed in a few hours

Thanks for reporting this. Smile


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - SkyLineRxx - 2009-11-28

Thanks G33k. Now it works!

Also how come admin can't press thanks?


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - spinning - 2009-11-29

Problem!!!
When you install the plugin, the templates are not changed.
The reason for this because of template changes by other plugins.
Can you tell me exactly what lines must be added in the different templates.


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - Alan S. - 2009-11-30

Excellent plugin, thanks!


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - - G33K - - 2009-11-30

(2009-11-28, 11:53 PM)SkyLineRxx Wrote: Also how come admin can't press thanks?

Admin can Thank/Like just like every other user. The only time a user can not Thank/Like a post is if they are the post owner, the post is in an excluded forum, the post is not the first post and the settings are set to thank/like only in first post, the thread is closed. Check to make sure none of these apply.

(2009-11-29, 08:00 PM)spinning Wrote: Problem!!!
When you install the plugin, the templates are not changed.
The reason for this because of template changes by other plugins.
Can you tell me exactly what lines must be added in the different templates.

http://community.mybboard.net/thread-59652-post-426555.html#pid426555

(2009-11-30, 02:11 AM)AJS Wrote: Excellent plugin, thanks!

You're welcome.


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - spinning - 2009-11-30

I am trying to get for over 30 minutes now the buttons in the classic templates but do not work.
I am 100% sure the pluggin is installed because in the member info behind the post you can read: Thanks Received: 0 in 0 posts, but no buttons in postit.


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - Leefish - 2009-11-30

Hi, sorry to join in with the yells for help, but I have a problem with using this with the aardvark theme. I have a button everywhere where a button should be - unfortunately the aardvark theme has no buttons so this one looks a bit strange. Can you tell me where I need to edit in the aardvark templates to REMOVE the button and just be left with the text like the rest of the theme? Im guessing I need to edit in the post template, as I obviously cant edit in the globals without smashing all the other themes....(I think?)

I know this is not a problem with the plug in (its doing JUST what it said it would Big Grin ) but I would appreciate it if you could help.

thanks

Lee
Hi
I made some buttons for this for my own site to use with some of the Afresh themes. Just thanks buttons, and only for the themes I have installed:

Mint/Midnight/Black/Orange/Sun.

They are not PERFECT - but I thought they were good enough for my forum and maybe someone might be interested. I hope its ok to post them - if not, Im sorry. If its ok - well, enjoy.

See screenshot.
[attachment=16262]


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - - G33K - - 2009-12-01

(2009-11-30, 08:15 PM)spinning Wrote: I am trying to get for over 30 minutes now the buttons in the classic templates but do not work.
I am 100% sure the pluggin is installed because in the member info behind the post you can read: Thanks Received: 0 in 0 posts, but no buttons in postit.

You had a similar problem with my Its My Birthday plugin and the cause was you didn't have the buttons in the right folder. Please check that the images are there in the right folders.

* /images/english/postbit_l_add.gif
* /images/english/postbit_l_add.gif
* /images/english/postbit_ty_add.gif
* /images/english/postbit_ty_add.gif

^Thats for a default theme, and english language. If you're using a non-default theme or a language other than english then you need to copy or make your own buttons and put them in images/<theme>/<lang>/

(2009-11-30, 09:16 PM)leesester Wrote: Hi, sorry to join in with the yells for help, but I have a problem with using this with the aardvark theme. I have a button everywhere where a button should be - unfortunately the aardvark theme has no buttons so this one looks a bit strange. Can you tell me where I need to edit in the aardvark templates to REMOVE the button and just be left with the text like the rest of the theme? Im guessing I need to edit in the post template, as I obviously cant edit in the globals without smashing all the other themes....(I think?)

I know this is not a problem with the plug in (its doing JUST what it said it would Big Grin ) but I would appreciate it if you could help.

thanks

Lee

The post buttons can be edited under global templates>thankyoulike_button_add and thankyoulike_button_del.
However, I assume you have multiple themes installed. With multiple themes, I recommend you not edit the global templates as doing so will change the look in all themes. To change the button look(changing it to text) for a specific theme, create a new template for the buttons under the themes template and edit it there.
For example
Assuming the aardvark theme is linked to the aardvark template set then here is what you can do:

Under the aardvark templates, click on add template and enter the following:

Title: thankyoulike_button_add
<span id="tyl_btn_{$post['pid']}"><a href="thankyoulike.php?action=add&pid={$post['pid']}" onclick="return thankyoulike.add({$post['pid']}, {$post['tid']});" title="{$lang->add_tyl}" id="tyl_a{$post['pid']}">{$lang->add_tyl}</a></span>

Save

Repeat the above again for the following:
Title: thankyoulike_button_del
<span id="tyl_btn_{$post['pid']}"><a href="thankyoulike.php?action=del&pid={$post['pid']}" onclick="return thankyoulike.del({$post['pid']}, {$post['tid']});" title="{$lang->del_tyl}" id="tyl_a{$post['pid']}">{$lang->del_tyl}</a></span>

The above two templates will be saved under Ungrouped Templates in the aardvark template set. You can do the above for any other template that you want to make specific to a theme.

Hope that helps and let me know if you need any more info.

Quote:Hi
I made some buttons for this for my own site to use with some of the Afresh themes. Just thanks buttons, and only for the themes I have installed:

Mint/Midnight/Black/Orange/Sun.

They are not PERFECT - but I thought they were good enough for my forum and maybe someone might be interested. I hope its ok to post them - if not, Im sorry. If its ok - well, enjoy.

See screenshot.

Thanks, I'll edit the main post with link to your post for the buttons.


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - Leefish - 2009-12-01

Thank you very much for the help on the template, it worked. Now I have a buttonless aardvark theme - just text - which is EXACTLY what I wanted. Thank you again (Now wheres that thanks button on this thread... Wink )