MyBB Community Forums
[1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) (/thread-59652.html)



RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - Nayar - 2010-06-02

I noticed that guests could see the thank button.
Open inc/plugins/thankyoulike.php
Change
if(($tyled && $mybb->settings[$prefix.'removing'] != "1") || (!is_moderator($post['fid'], "caneditposts") && $thread['closed'] == 1) || $post['uid'] == $mybb->user['uid'])
To
if(($tyled && $mybb->settings[$prefix.'removing'] != "1") || (!is_moderator($post['fid'], "caneditposts") && $thread['closed'] == 1) || $post['uid'] == $mybb->user['uid'] || $mybb->user['uid'] == 0)

This shall disable guests to view the thank botton.
//Use this code at your own risk


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - delphi.momod - 2010-06-04

Hi, thank you for this great MOD. It will be more powerful if you could add a HTNK (The tag hides content from people until they press the thank you button for the post).
HTNKC (The tag hides content from people that haven't received X thanks) also great!

Thank you


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - trulyhench.com - 2010-06-05

Hello guys I would love to install this mod but as a novice and after spending hours I still cant get the files in the right files.

Is there any one out there who could walk talk me through it on msn or something similar?


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - Bumiayu - 2010-06-06

myBB is perfect... the plugins is awesome Smile


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - Chrissy Poo - 2010-06-07

In the posts how can I change the text so instead of saying:

Thanks Received: 0 in 0 posts

it says:

Thanks Received: 0

??

Thanks in Advance Smile


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - Nayar - 2010-06-07

I changed it in my board.
Here's what to do:

Go to inc>languages>english>thankyoulike.lang.php

Open the file and change whatever you want


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - Chrissy Poo - 2010-06-07

Thank You Smile


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - Nayar - 2010-06-07

(2010-06-07, 12:11 PM)Chrissy Poo Wrote: Thank You Smile

you're welcome Smile


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - CynthiaL - 2010-06-24

Hello Nayar or any other dear soul willing to read this,

I see that G33K has not been online here since January so I was hoping to pick your brain a bit about this plugin.

My question pertains to an "active forum" but I also have a "test forum" and I need to differentiate between them to get to the juice of the matter. Shy

As mentioned by others in this thread I too get the "loading please wait" window that never goes away unless you refresh the page and then and only then does your thanks show up. This is on the active forum. On the test forum it works beautifully. Both are Windows Hosted at the moment, one at Godaddy and one at Aplus. Both are using the same Afresh Black theme. Can't be my IE8 as mentioned elsewhere as I use it to view/post at both forums.

I followed each and every step on page 6 and none of the code had to be written in as it is all there on both forums. The only thing different from the pg 6 instructions and what is on both forums is the following.

In the showthread template where he said to look for or add:

<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/thankyoulike.js?ver=100"></script>
<script type="text/javascript">
<!--
var tylEnabled = "{$mybb->settings['g33k_thankyoulike_enabled']}";
var tylCollapsible = "{$mybb->settings['g33k_thankyoulike_collapsible']}";
var tylUser = "{$mybb->user[\'uid\']}";
-->
</script>

Both forums have a 110 instead of a 100 after js?ver= and both forums have ['uid']} instead of [\'uid\']} but since the plugin works great on one and not the other I can't imagine that is the problem.

All other templates have what he wrote they should have.

Do you have any ideas we could try to get the system to work properly for the active forum?

Thanks for your time,

Cynthia


RE: [Release 1.4.x] Thank You/Like System (Update: v1.1 Released) - Nayar - 2010-06-24

@Cynthial:
I'm sorry but i don't know anything about AJAX. I am n00b
Maybe someone else could help Smile