MyBB Community Forums
[1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) (/thread-59652.html)



RE: [Release 1.4/1.6] Thank You/Like System (Update: v1.2 Released) - DersimliErsin - 2010-11-14

(2010-11-14, 07:45 AM)- G33K - Wrote: I'm sorry but your post was not very clear but I think you are having problems with the templates? What did you fix? What was not working?

What do you want to fix in the global templates? Those templates should be automatically added when you install the plugin. Could you please be alittle more clear?

When you install the plugin do the templates not get edited/added?

First, thank you for answer...

i made exactly that what you wrote:

i uploaded the plugin via FTP in my "mybb" root, after then i activated and installed the Thank You/Like mod. Under the template-sets / Globale Templates you can see the thankyoulike mods. The problem is, the plugin works perfect if i use the standard theme (Default Theme), but if i change the theme to my own theme (Blue Warez 2.0), "the thank you" mod disappears. So what have i done? I followed your construction. Under Globale Templates:

1. I copied the template "thank youlike" into my own theme: Blue Warez 2.0 Templates / Post Bit Templates / postbit

2. The templates thankyoulike_button_add and thankyoulike_button_del i copied from Globale Templates to Blue Warez 2.0 Templates / Post Bit Templates / postbit and Post Bit Templates / postbit_classic

3. thankyoulike_expcollapse i didnt copy, because i dont know in which templates of my Blue Warez Theme i must put in.

4. thankyoulike_memprofile i copied from Globale Templates to Blue Warez 2.0 / Member Templates / member_profile ..it works very good, you can see in the profile the number of Thank You/Likes, but in the bracket is no stats...just a bracket. Look at this link:

http://www.koyedersim.com/forum/member.php?action=profile&uid=2

5. thankyoulike_users i didnt copy, because i dont know in which templates of my Blue Warez Theme i must put in.

6. Show Thread Templates / showthread this one i didnt understand. I tried to put the code of the jscript inside the showtread...but it doesnt work. I get a error.

7. Post Bit Templates / postbit_author_user, i also didnt edit, because i dont know which one of Globale Templates i must copy?


I hope that my post was now more detailed. I must also say, that i use for my admin-panel the german languague and for my forum (for the user) the turkish languague. I am turkish and live in germany, i can better edit and understand in german...but my user comes from turkey, thats the reason why i changed the boards of turkish but not the admin panel...thats of german.....anyway...i hope so much to fix this problem as soon as possible.

Note: I uploaded the ordner "Thank You / Like System" languague concerning also in the german and turkish ordner...otherwise you can not see plugin...my forum is not of english.



RE: [Release 1.4/1.6] Thank You/Like System (Update: v1.2 Released) - - G33K - - 2010-11-15

I see. I understand now. I must say, you messed it up pretty good :p
The global templates should remain in global templates, they do not need to copied to your theme. So here is what you need to do.
- Undo everything you've done so far. This includes all template edits you made copying from the global template
- Uninstall the plugin.
- Install/Activate the plugin.

Now here are the template edits that need to go in your theme (if they are not there automatically)

Template: showthread
Find:
</head>
Add Before:
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/thankyoulike.js?ver=120"></script>
<script type="text/javascript">
<!--
	var tylEnabled = "{$mybb->settings['g33k_thankyoulike_enabled']}";
	var tylCollapsible = "{$mybb->settings['g33k_thankyoulike_collapsible']}";
	var tylUser = "{$mybb->user['uid']}";
-->
</script>

Template: postbit
Find:
</tbody>
Add Before:
	<tr style="{$post['tyl_display']}" id="tyl_{$post['pid']}">
			{$post['thankyoulike_data']}
		</tr>

Template: postbit
Find:
{$post['button_edit']}
Add Before:
{$post['button_tyl']}

Template: postbit_classic
Find:
</tr>
</table>
Add Before:
</tr>
<tr style="{$post['tyl_display']}" id="tyl_{$post['pid']}">
	{$post['thankyoulike_data']}

Template: postbit_classic
Find:
{$post['button_edit']}
Add Before:
{$post['button_tyl']}

Template: postbit_author_user
Find:
	{$lang->postbit_posts} {$post['postnum']}<br />
Add After:
	%%TYL_NUMTHANKEDLIKED%%<br />

Template: member_profile
Find:
<td class="trow1">{$memprofile['postnum']} ({$lang->ppd_percent_total})<br /><span class="smalltext">(<a href="search.php?action=finduserthreads&amp;uid={$uid}">{$lang->find_threads}</a> &mdash; <a href="search.php?action=finduser&amp;uid={$uid}">{$lang->find_posts}</a>)</span></td>
</tr>
Add After:
{$tyl_memprofile}




RE: [Release 1.4/1.6] Thank You/Like System (Update: v1.2 Released) - DersimliErsin - 2010-11-15

You are really the best! Its still not perfect, but it looks now much better! Because there is just a small mistakes...i can show you:

1. In the Profile you will see to times "Total Thanks Given" ...i want to delete the first one:

[attachment=20516]


2. In this screenshot you can see three times the thank you post...but i want just one:

[attachment=20517]


3. And the last thing...i have in the index of my forum a stats plugin...you can see a lot stats about the forum and the user...there is also a thanks blog in the right side, but it doesnt work. Do you know how to fix it? It calls: "ProStats (1.7.5)" made by SaeedGh.

[attachment=20518]


Oooooh...

i realize now that i deleted the add and delete button Sad. Please can you show me, how to add the buttons again?
as guest you can see the add button...but two times...and as user you will not see the thanks button:

Look at this:

[attachment=20519]


RE: [Release 1.4/1.6] Thank You/Like System (Update: v1.2 Released) - - G33K - - 2010-11-15

The double entries are because there are multiple entries in the templates, possibly because the plugin added one automatically then you went ahead and added another. You need to go through the templates I mentioned in my previous post and make sure the elements are there only once and not multiple times.

If you want I can set it up for you as I feel it would be easier than going back and forth here. If you want me to do it for you, set me up with a temporary admin account and PM me the details. Otherwise just check the templates as I stated above.

To add thanks details in prostats you'll need to edit the prostats plugin:
http://community.mybb.com/thread-59652-post-434368.html#pid434368


RE: [Release 1.4/1.6] Thank You/Like System (Update: v1.2 Released) - DersimliErsin - 2010-11-15

(2010-11-15, 09:37 PM)- G33K - Wrote: The double entries are because there are multiple entries in the templates, possibly because the plugin added one automatically then you went ahead and added another. You need to go through the templates I mentioned in my previous post and make sure the elements are there only once and not multiple times.

If you want I can set it up for you as I feel it would be easier than going back and forth here. If you want me to do it for you, set me up with a temporary admin account and PM me the details. Otherwise just check the templates as I stated above.

To add thanks details in prostats you'll need to edit the prostats plugin:
http://community.mybb.com/thread-59652-post-434368.html#pid434368



Okey....i sent you a message....

really you are very nice! Thank you a lot!


RE: [Release 1.4/1.6] Thank You/Like System (Update: v1.2 Released) - - G33K - - 2010-11-16

(2010-11-15, 11:22 PM)DersimliErsin Wrote:
(2010-11-15, 09:37 PM)- G33K - Wrote: The double entries are because there are multiple entries in the templates, possibly because the plugin added one automatically then you went ahead and added another. You need to go through the templates I mentioned in my previous post and make sure the elements are there only once and not multiple times.

If you want I can set it up for you as I feel it would be easier than going back and forth here. If you want me to do it for you, set me up with a temporary admin account and PM me the details. Otherwise just check the templates as I stated above.

To add thanks details in prostats you'll need to edit the prostats plugin:
http://community.mybb.com/thread-59652-post-434368.html#pid434368



Okey....i sent you a message....

really you are very nice! Thank you a lot!

Ok, fixed the templates and the plugin works. The reason you can see the thank you buttons for guests but not when logged in is because once you thank a thread, you can not thank for it again so the button is hidden. You were looking at threads that you yourself thanked so the button got hidden. If you change the plugin settings to allow removal of thanks then the button instead of being hidden will change to a remove thanks button.




RE: [Release 1.4/1.6] Thank You/Like System (Update: v1.2 Released) - DersimliErsin - 2010-11-16

Oki doki...

you made a great job! The plugin is now working, finally.

Thank you for your time.


RE: [Release 1.4/1.6] Thank You/Like System (Update: v1.2 Released) - shoaib - 2010-11-22

my thank you/like counter is not working, what can be the problem?


RE: [Release 1.4/1.6] Thank You/Like System (Update: v1.2 Released) - - G33K - - 2010-11-23

(2010-11-22, 11:19 AM)shoaib Wrote: my thank you/like counter is not working, what can be the problem?

Without more info I can't really help you. The plugin works fine and if its not counting for you then you have something causing a conflict. There is a thank you count functionality in admincp>tools that you can use to recount the thanks, that would be a start in troubleshooting this.


RE: [Release 1.4/1.6] Thank You/Like System (Update: v1.2 Released) - shoaib - 2010-11-23

(2010-11-23, 12:34 AM)- G33K - Wrote:
(2010-11-22, 11:19 AM)shoaib Wrote: my thank you/like counter is not working, what can be the problem?

Without more info I can't really help you. The plugin works fine and if its not counting for you then you have something causing a conflict. There is a thank you count functionality in admincp>tools that you can use to recount the thanks, that would be a start in troubleshooting this.

yes i am talking about that, it makes all count to zero, once i start it.