MyBB Community Forums
[1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) (/thread-59652.html)



RE: [1.4.x/1.6.x] Thank You/Like System v1.4 (Updated: 07/31/2011) - leealex - 2011-10-21

(2011-09-03, 04:22 AM)echofloripa Wrote: Hi

After I made the upgrade to mynn 1.6.4, searching for all thanks shows an error to a few users. I can't reproduce myself, not sure why.

But below is the screenshot of the error:

[Image: bwme4ix4by3um1v9t.jpg]

Then with the same link I checked the mysql generated, and it seems different from the one that shows in the error message.

Error:
Quote:SELECT pid FROM mybb_posts WHERE pid
IN ( SELECT tyl.pid FROM mybb_g33k_thankyoulike_thankyoulike tyl
WHERE tyl.puid = 1620)
AND fid NOT IN ('56','67','30','39')
AND ((fid IN(56)
AND t.uid='1620')
OR t.fid NOT IN(56))
ORDER BY dateline DESC

No Error:
Quote:SELECT p.*, u.username AS userusername, t.subject AS thread_subject, t.replies AS thread_replies, t.views AS thread_views, t.lastpost AS thread_lastpost, t.closed AS thread_closed, t.uid AS thread_uid, tyl.dateline AS tyl_dateline FROM mybb_posts p LEFT JOIN mybb_threads t ON (t.tid=p.tid) LEFT JOIN mybb_users u ON (u.uid=p.uid) LEFT JOIN mybb_g33k_thankyoulike_thankyoulike tyl ON (tyl.pid=p.pid AND tyl.uid=1620) WHERE p.pid IN (12591,22297,25365,28708,29940) ORDER BY tyl.dateline desc LIMIT 0, 255

They seem like they are doing different stuff though...

I have the same problem Sad

[Image: BV0ObM64g0GvEveZOuOQg.jpg]
http://vitz55.ru/user-1.html

I tryed to delete the old files and replace them with the new ones, that didn't help, still getting this error Sad
It happens when I'm trying to search posts that I get "Thank" for. When I'm searching threads there's no any errors.


RE: [1.4.x/1.6.x] Thank You/Like System v1.4 (Updated: 07/31/2011) - - G33K - - 2011-10-21

^ What's your MyBB version?


RE: [1.4.x/1.6.x] Thank You/Like System v1.4 (Updated: 07/31/2011) - leealex - 2011-10-21

1.6.4


RE: [1.4.x/1.6.x] Thank You/Like System v1.4 (Updated: 07/31/2011) - - G33K - - 2011-10-21

Are you running the latest version of the plugin? Make sure you overwrite tylsearch.php file with one from the latest version of the plugin. I can't produce this error on my setup with v1.6.4 so its probably a file on your end that has not been replaced during the plugin update. A few hosts do not overwrite files so you might want to try deleting the file first then uploading the new one.


RE: [1.4.x/1.6.x] Thank You/Like System v1.4 (Updated: 07/31/2011) - leealex - 2011-10-21

I didn't actually replaced files, I deleted all files manualy and then I uploaded new ones.
Mybb 1.6.4 Plugin 1.4
http://vitz55.ru/tylsearch.php?action=usertylforposts&uid=1


RE: [1.4.x/1.6.x] Thank You/Like System v1.4 (Updated: 07/31/2011) - - G33K - - 2011-10-21

(2011-10-21, 06:55 AM)leealex Wrote: I didn't actually replaced files, I deleted all files manualy and then I uploaded new ones.
Mybb 1.6.4 Plugin 1.4
http://vitz55.ru/tylsearch.php?action=usertylforposts&uid=1

http://vitz55.ru/tylsearch.php?action=usertylforposts&uid=1 works fine for me, I don't see any error message


RE: [1.4.x/1.6.x] Thank You/Like System v1.4 (Updated: 07/31/2011) - leealex - 2011-10-21

Are you serious?!
that's what I see:
[Image: ee46bDwVxUKEn9RQ5zYlcw.jpg]


RE: [1.4.x/1.6.x] Thank You/Like System v1.4 (Updated: 07/31/2011) - - G33K - - 2011-10-21

Yes, very serious:

[Image: screenij.jpg]

Try running the Recount and Rebuild thanks in tools and maintenance section and clearing your cache and cookies. I will try and investigate more on my end why this might be happening but till I can actually reproduce the error its going to be difficult.


RE: [1.4.x/1.6.x] Thank You/Like System v1.4 (Updated: 07/31/2011) - leealex - 2011-10-22

I ran Recount, cleared cache and it helped Smile
Thank you


RE: [1.4.x/1.6.x] Thank You/Like System v1.4 (Updated: 07/31/2011) - LeeUk - 2011-10-24

Great plugin looks perfect on my forum, thank you very much for the share.