MyBB Community Forums
[1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) (/thread-59652.html)



RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - Freezing - 2012-06-23

EDIT:

I figured it out.

Thank you for the plugin!


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - niere8 - 2012-07-02

I have a problem with this plugin, when I click on "thank you" I see only loading window, then I must refresh page to see the "thank you" for user.


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - - G33K - - 2012-07-04

(2012-07-02, 06:38 PM)niere8 Wrote: I have a problem with this plugin, when I click on "thank you" I see only loading window, then I must refresh page to see the "thank you" for user.

Make sure you do not have any other javascripts that are conflicting with the jscripts of the plugin. Also make sure if you are using jquery you have resolved any incompatibilities.

If you are sure there is no jscript conflict then check the templates are edited as outlined in this post:
http://community.mybb.com/thread-59652-post-599058.html#pid599058
making sure you keep the same ids of the elements.


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - niere8 - 2012-07-04

All edits are ok.. then is a javascripts conflict? Sad


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - GunnerAIO - 2012-07-12

javascript conflict? .... eh. Just so you know I left a review that this didn't work for me, so I understand if you don't want to help me, but here's what happened:
[Image: attachment.php?aid=26805]
[attachment=26805]
locks on ajax load just like others have complained about.

After refresh, what supposed to be displayed in postbit completely disappears yet the code snippet in postbit template was still intact.
[Image: attachment.php?aid=26806]
[attachment=26806]
Also the plugin didn't add any code snippet in member profile template for stat section.

Running:
Admin CP Honeypot (1.0) MyBBWebHost
Advanced Quick Reply Form (1.0.3) Phenomenon
Advanced MyCode Permissions (1.4) Jammerx2
Default Avatar (1.0) Santiago Dimattia
Donation Page (2.1) MyBBWebHost
Forum Icons (3.0) Jesse Labrocca
Game Section (1.2.1) Paretje
Google SEO (1.6.3) Andreas Klauer
Its My Birthday! (2.2) - G33K -
Mods Cant Edit Admins Posts (1.1) Jammerx2
ModNotice Plus (1.5.2) Prtik
My Awards (2.3) Jesse Labrocca
MyBBpublisher (1.7.0) CommunityPlugins.com
Private Messages Admin (2.4.3) Aaron
Advanced Rainbow Colors For All Links (1.0) GodFather
SCD Hide From Groups (Free SCD Plugin) (2.5) Dylan Myers
Sig Image Size (1.0) Jesse Labrocca
Staff Online (0.1) Yaldaram


As far as what I already have installed, there's absolutely NO issues except for with ModNotice Plus (1.5.2) by Prtik with it's weird single postbit button formatting that not editable in templates.

Only of few of these use their own javascripts...
what's causing your plugin not to work?


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - niere8 - 2012-07-12

Did you try with Default Theme?
Thank You/Like System plugin works to me but only with Default Theme Sad

In showthread I have always two times:

<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/thankyoulike.js?ver=150"></script>
<script type="text/javascript">
<!--
	var tylEnabled = "{$mybb->settings['g33k_thankyoulike_enabled']}";
	var tylCollapsible = "{$mybb->settings['g33k_thankyoulike_collapsible']}";
	var tylUser = "{$mybb->user['uid']}";
-->
</script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/thankyoulike.js?ver=150"></script>
<script type="text/javascript">
<!--
	var tylEnabled = "{$mybb->settings['g33k_thankyoulike_enabled']}";
	var tylCollapsible = "{$mybb->settings['g33k_thankyoulike_collapsible']}";
	var tylUser = "{$mybb->user['uid']}";
-->
</script>
</head>


EDIT: now it works :o I don't know how but it is Ok Big Grin


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - GunnerAIO - 2012-07-12

(2012-07-12, 11:25 AM)niere8 Wrote: Did you try with Default Theme?
Thank You/Like System plugin works to me but only with Default Theme Sad

In showthread I have always two times:

<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/thankyoulike.js?ver=150"></script>
<script type="text/javascript">
<!--
	var tylEnabled = "{$mybb->settings['g33k_thankyoulike_enabled']}";
	var tylCollapsible = "{$mybb->settings['g33k_thankyoulike_collapsible']}";
	var tylUser = "{$mybb->user['uid']}";
-->
</script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/thankyoulike.js?ver=150"></script>
<script type="text/javascript">
<!--
	var tylEnabled = "{$mybb->settings['g33k_thankyoulike_enabled']}";
	var tylCollapsible = "{$mybb->settings['g33k_thankyoulike_collapsible']}";
	var tylUser = "{$mybb->user['uid']}";
-->
</script>
</head>


EDIT: now it works :o I don't know how but it is Ok Big Grin

I don't use default theme, I use a mis-mash of code snippets for my current theme but it's very functional. The above code you've quoted was not added in ANY of my theme templates so I'm guessing this may be the big piece I'm missing.. would make sense.. I'll re-install it and give this code a try. Thank you niere8! +rep

Edit:
I forgot to ask, do you have to code snippet for the thanks in profile template for stats?


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - niere8 - 2012-07-12

I had delete only one time the code over, now in showthread I have:

<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/thankyoulike.js?ver=150"></script>
<script type="text/javascript">
<!--
	var tylEnabled = "{$mybb->settings['g33k_thankyoulike_enabled']}";
	var tylCollapsible = "{$mybb->settings['g33k_thankyoulike_collapsible']}";
	var tylUser = "{$mybb->user['uid']}";
-->
</script>
just above of:
</head>

If I click on "thank you", I don't have "window download" but a "redirect page", anyway plugin now works. In postbit user details I have stats.

I have copy-paste all codes from here: http://community.mybb.com/thread-59652-post-599058.html#pid599058


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - - G33K - - 2012-07-13

@GunnerAIO

Anytime a user has come here for support with this plugin not working, the first thing I have asked them to do is check and make sure that all the template edits are there. Even on this very page I have posted this link: http://community.mybb.com/thread-59652-post-599058.html#pid599058 where you can check which template edits are supposed to be made.
By your own admission some of the required edits are not there so the first thing you should do is check that all the edits are there.
The plugin makes template edits using a search/replace function but for themes that are radically different from the default theme's templates it will obviously not find the relevant elements to make the edits in which case you would need to manually make the edits as per the above posted link.

If the edits are all there and it still does not work then it is time to check if there is a javascript conflict. Keep in mind that javascripts don't come with plugins only, alot of themes also come with their own javascripts so you need to check to make sure that you don't have a javascript conflicting.


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - kjaonline - 2012-07-16

Is there any way to list users according to the number of likes/thanks they received?