MyBB Community Forums
[1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) (/thread-59652.html)



RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - Darth Apple - 2014-09-10

(2014-09-10, 06:14 AM)Adzdon Wrote: I'm having a problem when i installed this.... Whenever a user clicks 'Like' on a post, It shows up a 'Loading' box and it doesn't disappear?

What other plugins do you have installed? I know there is at least a conflict with the shoutbox plugin.


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - Adzdon - 2014-09-10

(2014-09-10, 06:17 AM)Darth Apple Wrote:
(2014-09-10, 06:14 AM)Adzdon Wrote: I'm having a problem when i installed this.... Whenever a user clicks 'Like' on a post, It shows up a 'Loading' box and it doesn't disappear?

What other plugins do you have installed? I know there is at least a conflict with the shoutbox plugin.

Yeah, I've got a shoutbox installed. It's called ' [AJAX] Inferno Shoutbox'
Is that the issue?


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - Darth Apple - 2014-09-10

(2014-09-10, 06:19 AM)Adzdon Wrote:
(2014-09-10, 06:17 AM)Darth Apple Wrote:
(2014-09-10, 06:14 AM)Adzdon Wrote: I'm having a problem when i installed this.... Whenever a user clicks 'Like' on a post, It shows up a 'Loading' box and it doesn't disappear?

What other plugins do you have installed? I know there is at least a conflict with the shoutbox plugin.

Yeah, I've got a shoutbox installed. It's called ' [AJAX] Inferno Shoutbox'
Is that the issue?

I only ever had issues with MyShoutbox, but I haven't tried inferno shoutbox. It might be good to try randomly disabling plugins and seeing if that explains anything. If it's just hanging up on the loading gif, that sounds like some sort of javascript conflict from a plugin.


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - Adzdon - 2014-09-10

(2014-09-10, 06:20 AM)Darth Apple Wrote:
(2014-09-10, 06:19 AM)Adzdon Wrote:
(2014-09-10, 06:17 AM)Darth Apple Wrote:
(2014-09-10, 06:14 AM)Adzdon Wrote: I'm having a problem when i installed this.... Whenever a user clicks 'Like' on a post, It shows up a 'Loading' box and it doesn't disappear?

What other plugins do you have installed? I know there is at least a conflict with the shoutbox plugin.

Yeah, I've got a shoutbox installed. It's called ' [AJAX] Inferno Shoutbox'
Is that the issue?

I only ever had issues with MyShoutbox, but I haven't tried inferno shoutbox. It might be good to try randomly disabling plugins and seeing if that explains anything. If it's just hanging up on the loading gif, that sounds like some sort of javascript conflict from a plugin.

My forum is using CloudFlare, Well i'm not sure if that's the problem or it's the shoutbox... hmm....


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - Darth Apple - 2014-09-10

(2014-09-10, 06:22 AM)Adzdon Wrote: My forum is using CloudFlare, Well i'm not sure if that's the problem or it's the shoutbox... hmm....

If ajax based requests are working everywhere else on your forum, I don't imagine cloudflare could be the issue. You'd probably know if cloudflare was breaking ajax requests on your forum because a lot would end up broken.

Edit: didn't think about caching... I suppose it's a possibility.


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - .m. - 2014-09-10

development mode at cloudflare  should be turned on before modifying java script & css .. etc


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - Adzdon - 2014-09-10

How do you know that? I mean that is something i don't use when I'm editing stuff on my website/forum?


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - .m. - 2014-09-10

^ exact caching by cloudflare is difficult to trace without using a good plugin (eg. CloudFlare Manager)
in general, we suggest to turn on the development mode before modifying css & java script and images ..

however you can temporarily deactivate inferno shoutbox & check if modified Thank You / Like system works as expected


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - jdmmer - 2014-09-11

It works here too but not 100%.

When you press the Like button, the cursor changes to a loading animation and you have to refresh the page to see the link underneath the post. I've used the download of My-BB.Ir.

Any idea why? I don't have a shoutbox plugin installed.


RE: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - Come On Thru - 2014-09-15

(2014-09-08, 11:36 PM)My-BB.Ir Wrote: Download for 1.8:  http://community.mybb.com/thread-59652-post-1100852.html#pid1100852
Smile

This one is missing in your ported version, could you add this?

[Image: 2014-09-15_1315.png]

Added {$tyl_memprofile} to member_profile template, now in user profile numbers of likes are shown, but when I press (Find All Thanked Threads  or Find All Thanked Posts) it gives:
Sorry, but no results were returned using the query information you provided. Please redefine your search terms and try again.

Maybe someone could help?