MyBB Community Forums
[1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [1.4.x/1.6.x] Thank You/Like System v1.5 (Updated: 10/26/2011) (/thread-59652.html)



RE: [Release 1.4.x] Thank You/Like System - atomjani - 2009-11-18

(2009-11-17, 11:09 PM)- G33K - Wrote:
(2009-11-17, 10:22 AM)atomjani Wrote: I like two button:
-good post (and "remove good post")
-bad post (and "remove bad post")
If I click to "good", I see "remove good" or "bad post". If i click "bad post", the will changing to "bad post".
If I click to "bad", I see "remove bad" or "good post". If i click "good post", the will changing to "good post".
What have I doing?

This will require a modification of this mod, not something I would do but you are free to make the modifications to suit your needs.

I understand. And "Like" and "Not Like" alternative selections with together? If like me the post, then i click "Like" button. And If not like me the post, then i click "Not like" button. I can't making plugin.


RE: [Release 1.4.x] Thank You/Like System - - G33K - - 2009-11-18

(2009-11-18, 07:12 AM)acrox999 Wrote:
(2009-11-17, 09:49 PM)bold_handsome Wrote: nice mod working gr8 on my forum but i found one unexpected issue see the pic i think its them editing prob no one still give thanks this user may be thats why showing like this how i fix this

Oh yeah, I got that problem when viewing PM. In forums, it show correctly.

Oh wow! I forgot about the postbit user stats in the PM section. I'll fix this in the next release.


RE: [Release 1.4.x] Thank You/Like System - acrox999 - 2009-11-18

Ok, thanks!


RE: [Release 1.4.x] Thank You/Like System - bold_handsome - 2009-11-18

(2009-11-18, 07:12 AM)acrox999 Wrote:
(2009-11-17, 09:49 PM)bold_handsome Wrote: nice mod working gr8 on my forum but i found one unexpected issue see the pic i think its them editing prob no one still give thanks this user may be thats why showing like this how i fix this

Oh yeah, I got that problem when viewing PM. In forums, it show correctly.

(2009-11-18, 08:06 AM)- G33K - Wrote:
(2009-11-18, 07:12 AM)acrox999 Wrote:
(2009-11-17, 09:49 PM)bold_handsome Wrote: nice mod working gr8 on my forum but i found one unexpected issue see the pic i think its them editing prob no one still give thanks this user may be thats why showing like this how i fix this

Oh yeah, I got that problem when viewing PM. In forums, it show correctly.

Oh wow! I forgot about the postbit user stats in the PM section. I'll fix this in the next release.

sorry for late yes its only show on member pm i already check all code only member profile section code is not edited i have to put this code manually by given instruction works good and wi8 for next updates gr8 work Big Grin


RE: [Release 1.4.x] Thank You/Like System - MadamZuZu - 2009-11-18

(2009-11-17, 11:09 PM)- G33K - Wrote: This is most probably caused by a missing edit in the template. The plugin uses a search and replace to add items to templates, if you have a non-default template it is possible that the plugin did not insert all the elements it needed in to the templates. Check that the following edits are there in the templates, if they're not, add them.

i was missing some code, that fixed it,

but the likes in the postbit are always 0, and when i click on "search likes" in the profile i get a sql error:

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECT tyl.pid FROM myXg33k_thankyoulike_thankyoulike t
Query:
SELECT pid FROM myXrposts WHERE pid IN ( SELECT tyl.pid FROM myXg33k_thankyoulike_thankyoulike tyl WHERE tyl.uid = 25) ORDER BY dateline DESC



RE: [Release 1.4.x] Thank You/Like System - spinning - 2009-11-18

ProStats also use a thank you string.
In a earlier post (http://community.mybboard.net/thread-58257.html) you said that your plugin will easy to intergrate in ProStats.
Can you tell me how??


RE: [Release 1.4.x] Thank You/Like System - - G33K - - 2009-11-18

(2009-11-18, 04:36 PM)MadamZuZu Wrote:
(2009-11-17, 11:09 PM)- G33K - Wrote: This is most probably caused by a missing edit in the template. The plugin uses a search and replace to add items to templates, if you have a non-default template it is possible that the plugin did not insert all the elements it needed in to the templates. Check that the following edits are there in the templates, if they're not, add them.

i was missing some code, that fixed it,

but the likes in the postbit are always 0, and when i click on "search likes" in the profile i get a sql error:

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECT tyl.pid FROM myXg33k_thankyoulike_thankyoulike t
Query:
SELECT pid FROM myXrposts WHERE pid IN ( SELECT tyl.pid FROM myXg33k_thankyoulike_thankyoulike tyl WHERE tyl.uid = 25) ORDER BY dateline DESC

That is interesting. The syntax is right and its working on all the systems I've tried it on. Try re-downloading and re-uploading the /tylsearch.php file, maybe it got corrupted while uploading or something.
If that doesn't fix it then do you know what version of MySQL you're running? If no could you check and let me know. You can check mysql version in AdminCP>Tools>PHP Info

(2009-11-18, 07:54 PM)spinning Wrote: ProStats also use a thank you string.
In a earlier post (http://community.mybboard.net/thread-58257.html) you said that your plugin will easy to intergrate in ProStats.
Can you tell me how??

What?? Stop putting words in my mouth! I never said anything about prostats. In fact, I never even posted in that thread you mentioned, I think you're confusing me with ralgith.

However, since there are a couple of users who have asked about integrating it in to prostats, when I get time I will look at the prostats plugin and see what needs to be done in order to integrate it or at least show the thanks data in prostats.


RE: [Release 1.4.x] Thank You/Like System - MadamZuZu - 2009-11-18

i think it's this line:

SELECT tyl.pid FROM myXg33k_thankyoulike_thankyoulike tyl WHERE tyl.uid = 25

should it just be

SELECT tyl.pid FROM myXg33k_thankyoulike_thankyoulike WHERE tyl.uid = 25

?

thanks!


RE: [Release 1.4.x] Thank You/Like System - - G33K - - 2009-11-18

(2009-11-18, 09:59 PM)MadamZuZu Wrote: i think it's this line:

SELECT tyl.pid FROM myXg33k_thankyoulike_thankyoulike tyl WHERE tyl.uid = 25

should it just be

SELECT tyl.pid FROM myXg33k_thankyoulike_thankyoulike WHERE tyl.uid = 25

?

thanks!

No, that wouldn't work. It might just be a simple spacing issue.

Try this:

In the /tylsearch.php

Around Line 977, search for
$where_sql = "t.tid IN (
				SELECT p.tid 
				FROM ".TABLE_PREFIX.$prefix."thankyoulike tyl
				LEFT JOIN ".TABLE_PREFIX."posts p ON ( p.pid = tyl.pid )
				WHERE tyl.uid = $tyl_uid)";

Replace with
$where_sql = "t.tid IN (SELECT p.tid FROM ".TABLE_PREFIX.$prefix."thankyoulike tyl LEFT JOIN ".TABLE_PREFIX."posts p ON (p.pid = tyl.pid) WHERE tyl.uid = $tyl_uid)";

Around Line 1011, search for
$where_sql = "pid IN (
				SELECT tyl.pid 
				FROM ".TABLE_PREFIX.$prefix."thankyoulike tyl
				WHERE tyl.uid = $tyl_uid)";

Replace it with
$where_sql = "pid IN (SELECT tyl.pid FROM ".TABLE_PREFIX.$prefix."thankyoulike tyl WHERE tyl.uid = $tyl_uid)";



RE: [Release 1.4.x] Thank You/Like System - Dylan M. - 2009-11-18

(2009-11-18, 09:44 PM)- G33K - Wrote:
(2009-11-18, 04:36 PM)MadamZuZu Wrote:
(2009-11-17, 11:09 PM)- G33K - Wrote: This is most probably caused by a missing edit in the template. The plugin uses a search and replace to add items to templates, if you have a non-default template it is possible that the plugin did not insert all the elements it needed in to the templates. Check that the following edits are there in the templates, if they're not, add them.

i was missing some code, that fixed it,

but the likes in the postbit are always 0, and when i click on "search likes" in the profile i get a sql error:

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECT tyl.pid FROM myXg33k_thankyoulike_thankyoulike t
Query:
SELECT pid FROM myXrposts WHERE pid IN ( SELECT tyl.pid FROM myXg33k_thankyoulike_thankyoulike tyl WHERE tyl.uid = 25) ORDER BY dateline DESC

That is interesting. The syntax is right and its working on all the systems I've tried it on. Try re-downloading and re-uploading the /tylsearch.php file, maybe it got corrupted while uploading or something.
If that doesn't fix it then do you know what version of MySQL you're running? If no could you check and let me know. You can check mysql version in AdminCP>Tools>PHP Info

(2009-11-18, 07:54 PM)spinning Wrote: ProStats also use a thank you string.
In a earlier post (http://community.mybboard.net/thread-58257.html) you said that your plugin will easy to intergrate in ProStats.
Can you tell me how??

What?? Stop putting words in my mouth! I never said anything about prostats. In fact, I never even posted in that thread you mentioned, I think you're confusing me with ralgith.

However, since there are a couple of users who have asked about integrating it in to prostats, when I get time I will look at the prostats plugin and see what needs to be done in order to integrate it or at least show the thanks data in prostats.

And since you released yours I've but the alpha of mine away and not likely to be developed. Your system basically works as mine would, so I have no need to reinvent the wheel.