MyBB Community Forums
I just completed the install but have issues - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Support (https://community.mybb.com/forum-72.html)
+---- Thread: I just completed the install but have issues (/thread-79266.html)

Pages: 1 2


I just completed the install but have issues - djdubuque - 2010-09-29

Forum seems to fail...

The default forum will not allow me to view it, it will re-direct me to my home page of my site not the forum topic.

http://mysite.com/forum/Forum-Message-from-the-Admin-Staff

The above URL is what the forum points to but will not open, just re-directs to home page.

   


RE: I just completed the install but have issues - Alan S. - 2010-09-29

Can you provide the actual URL of your forum?


RE: I just completed the install but have issues - Alex Smith - 2010-09-29

A link to your site please as I don't really understand. All your screenshot shows is a forum. And, your link just confused me as it's not actually your site.

Edit: everytime ajs....


RE: I just completed the install but have issues - Matt - 2010-09-29

Not sure what you expect us to do with a mysite.com address...


RE: I just completed the install but have issues - djdubuque - 2010-09-29

Sorry, I thought I explained correctly.

http://10-6-club.com/forum


RE: I just completed the install but have issues - Matt - 2010-09-29

Looks like you've not made all the necessary .htaccess edits for the Google SEO plugin.

Reason we asked for a URL is because going to the home page, which is what you said, might be caused by something else wrong; we weren't sure if it said 404 or not (which it does).


RE: I just completed the install but have issues - Alan S. - 2010-09-29

Go to the ACP >> Configuration >> Plugins >> Google SEO and it should tell you what you need to do.


RE: I just completed the install but have issues - djdubuque - 2010-09-29

Quote:Google SEO (1.1.13)
Google Search Engine Optimization as described in the official Google's SEO starter guide. Please see the documentation for details.

* Add to .htaccess:

RewriteEngine on

# Google SEO workaround for search.php highlights:
# Make this rule the first rewrite rule in your .htaccess!
RewriteRule ^([^&]*)&(.*)$ http://10-6-club.com/forum/$1?$2 [L,QSA,R=301]

# Google SEO Sitemap:
RewriteRule ^sitemap-([^./]+)\.xml$ misc.php?google_seo_sitemap=$1 [L,QSA,NC]

# Google SEO URL Forums:
RewriteRule ^Forum-([^./]+)$ forumdisplay.php?google_seo_forum=$1 [L,QSA,NC]

# Google SEO URL Threads:
RewriteRule ^Thread-([^./]+)$ showthread.php?google_seo_thread=$1 [L,QSA,NC]

# Google SEO URL Announcements:
RewriteRule ^Announcement-([^./]+)$ announcements.php?google_seo_announcement=$1 [L,QSA,NC]

# Google SEO URL Users:
RewriteRule ^User-([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]

# Google SEO URL Calendars:
RewriteRule ^Calendar-([^./]+)$ calendar.php?google_seo_calendar=$1 [L,QSA,NC]

# Google SEO URL Events:
RewriteRule ^Event-([^./]+)$ calendar.php?action=event&google_seo_event=$1 [L,QSA,NC]

# Google SEO 404:
ErrorDocument 404 /forum/misc.php?google_seo_error=404

* 404, Meta, Redirect, Sitemap and URL are enabled.



RE: I just completed the install but have issues - Alan S. - 2010-09-29

It tells you what to do. Add what it lists to your .htaccess file.


RE: I just completed the install but have issues - Matt - 2010-09-29

As it says there, you have to add those rewrite rules to your .htaccess file...